Frequently Asked Questions (FAQs) for
Murach’s Dreamweaver CC 2014

How does the 2014.1 release of Dreamweaver CC affect how I work in Dreamweaver?

In October 2014, a new release of Dreamweaver CC became available. This release includes some changes to existing features as well as the addition of new features. Following is a summary of the features that affect the material presented in our book.

Extract panel

The first time you start Dreamweaver CC, an Extract panel is displayed at the left side of the IDE. You can use this panel to extract style information and assets from a Photoshop Document (PSD) file. If you use Photoshop, you can learn how to use this panel by clicking the Get Started button. Otherwise, you can close this panel by displaying the Options menu at the right side of the panel’s title bar and then choosing Close.

Default view for HTML documents

When you open an HTML document, it’s now displayed in Split view by default. This view is split horizontally with Live view on the top and Code view on the bottom. You can change this display using buttons on the Document toolbar and items in the View menu.

Improved layout of the Document toolbar

The Document toolbar has been simplified to make it easier to use. The new Document toolbar looks like this:

First, the Design and Live buttons have been combined into a single drop-down menu. Second, the field for entering the title for a page has been omitted. It can now be found in the Property Inspector or by choosing Modify ➔ Page Properties ➔ Title/Encoding. Third, the Live Code and Inspect buttons that are displayed in Live View are now icons. Fourth, the Back, Forward, and Refresh icons are grouped with the address bar and displayed in the center of the Document toolbar. And fifth, the Preview/Debug in Browser, Live View Options, and File Management icons are grouped together and displayed at the right side of the Document toolbar.
New features of Element Live Display
When you create a class or ID using Element Live Display, Dreamweaver displays options that let you choose the style sheet and media query you want to add the selector to as shown in the example that follows. If you want to add the selector to the style sheet that’s displayed by default and you don’t want to add the selector to a media query, you can press the Esc key to dismiss these options.

Moving elements in Live view
You can now move elements in Live view by dragging them from one location to another. When you do that, Dreamweaver indicates the element that the move is relative to by outlining it with a blue border, and a Live Guide appears indicating where the element will be positioned. In the example that follows, the third item in a list is being moved before the second item. For more information on Live Guides, see the topic on the next page.
New Live Guides feature in Live view

Live Guides indicate the position where an element will be placed when you drag it from the Insert or Assets panel or from another location on the page. An element can be placed above, below, to the right, or to the left of another element. In the example that follows, a `<p>` element is being placed below another `<p>` element.

![Live Guides Example](image)

You can also use Element Quick View along with Live Guides to position an element more precisely. To do that, point to the Element Quick View icon (<> that appears when inserting or moving an element in Live view (see above) to display Element Quick View. Then, drop the element exactly where you want it inside Element Quick View:

![Element Quick View Example](image)

Live view context menus

You can now use the context menu that’s displayed when you right-click an element in Live view to cut, copy, paste, and delete elements. You can also use this context menu to duplicate elements or select the parent or child tag of an element.
Improvements to the Quick Tag Editor

You can now press Ctrl+T (Windows) or Cmd+T (Mac) to display the Quick Tag Editor for the selected element. You can use the Quick Tag Editor to edit the tag, wrap the tag in another tag, or insert HTML into the tag. To toggle between these states, you use the same shortcut keys that you use to display this editor. In the example that follows, the tag for an image is displayed in its Edit Tag state.

Editing fluid grid documents in Live view

You can now use most of the editing features that were introduced for Live view in Dreamweaver CC 2014 with fluid grid documents. When you select an element in a fluid grid document in Live view, Element Live Display is now included along with the fluid grid options:

In addition, fluid grid documents can no longer be displayed or edited in Design view.

Inserting structural elements in a fluid grid document

When you insert a structural element in a fluid grid document, the Insert dialog box now includes icons that let you indicate the position of the inserted element relative to the selected element. An inserted element can be inserted before or after the selected element or nested within that element as shown below.
Automatic sync of Live view with Code view
If you’re working in Split view with Live view displayed and you make a change in Code view, the change is automatically reflected in Live view. You don’t have to click the Refresh icon to see the change.

Assets panel
The Assets panel is now available in Live view. However, the Scripts, Templates, and Library categories are hidden in Live view since they aren’t typically used in that view.

The Flash and Movies categories of the Assets panel have been combined into a single Media category.

jQuery and jQuery UI versions
Dreamweaver CC 2014.1 uses the most current, backwards compatible versions of jQuery (1.11.1) and jQuery UI (1.10.4).
How does the 2015 release of Dreamweaver CC affect how I work in Dreamweaver?

In June 2015, Dreamweaver CC 2015 became available. This release includes some changes to existing features as well as the addition of new features. Following is a summary of the features that affect the material presented in our book. These features are in addition to the new and changed features in the 2014.1 release of Dreamweaver CC.

Enhancements to Live view

To move an element in Live view, you now drag it by its tag name.

The following menus are now enabled in Live view: Modify, Format, Commands, and Site. The Paste Special option is also enabled in the Edit and context menus.

You can select multiple elements within a tag by clicking and dragging. This is called marquee selection.

You can insert jQuery UI widgets in Live view by dragging them from the Insert panel. When you do, you can use the same techniques to position the widget as you do structural elements.

You can use the formatting options of Element Live Display to work with a table. You can also use the options in the Modify → Table menu, which was previously disabled in Live view.

Element Quick View is now called the DOM panel.

Enhancements to Element Live Display

To make it clear that an ID or class can be specified in Element Live Display, the hint “Class/ID” is displayed as shown below.

![Our Solutions](image)

Also, once you enter a class or ID, you can save the changes by clicking the + icon as well as by pressing the Enter or Return key.

New preview features in Code view

You can preview an image by hovering the mouse over the URL for the image. You can also preview a color by hovering the mouse over the code for the color.
**Code folding in Code view**

*Code folding* is a new feature that lets you collapse and expand blocks of code. To collapse a block of code, hover the mouse over the line numbers to the left of the code and then click on the down arrow that appears for that block. To expand a block of code, hover the mouse over the line numbers and then click on the right arrow that appears for that block.
**Code linting**

*Code linting* is a new feature that provides for analyzing your HTML, CSS, and JavaScript files to identify errors or potential errors. Linting is enabled by default and is performed any time you open, edit, or save a file. To disable linting or to control when it’s performed, you can use the Linting category of the Preferences dialog box.

The linting feature displays error messages and warnings in the Output window that’s docked at the bottom of the IDE by default. As shown in the following screen shot, errors are identified by a red X and warnings are identified by a yellow exclamation mark (!). You can double-click on an error or warning to jump to the line of code that contains the error. The numbers of lines with errors or warnings are also color-coded in the Code view window, and you can hover the mouse over a line number to display the error or warning message.

The Linting icon in the status bar also indicates if there are errors or warnings or if no problems were found (a green check mark). If errors or warnings were found, you can click on this icon to open or close the Output panel. Otherwise, you can use the Window→Results→Output option.

**Changes to the Coding toolbar**

Because of the addition of code folding, the Collapse Full Tag and Collapse Selection icons have been removed from this toolbar as well as from the Edit and context menus.

Because of the addition of code linting, the Highlight Invalid Code and Syntax Error Alerts in Info Bar icons have been removed from this toolbar for HTML, CSS, and JavaScript files.
Changes to the CSS Designer

Two modes are provided for viewing and editing CSS properties as shown below.

With All, all of the CSS, media queries, and selectors for the document are listed. This mode is useful if you want to create style sheets, media queries, or style rules. With Current, the computed styles for the selected element are displayed. This is useful if you want to modify the styles for the element.

The + and – buttons at the top of each pane of the CSS Designer have been moved from the right to the left as shown above. In addition, the Show Set check box in the Properties pane is selected by default, and the Custom category at the bottom of the Properties pane is now called More.

Visual Media Queries

You can use the new Visual Media Queries feature to create media queries and to view a web page at the breakpoints set by different media queries. When you first display a web page in Live view, a blank Visual Media Query bar is displayed at the top of the window. If this bar isn’t displayed, you can click the Show/Hide Visual Media Queries bar icon near the right side of the Document toolbar.
To add a media query, you can drag the *scrubber* at the right side of the document window until the width of the window is equal to either the min-width or max-width value you want to use. Then, you can click on the triangle with the + sign in the ruler as shown below.

After you click this icon, the ruler to the left of the value is displayed in green and the ruler to the right of the value is displayed in purple.

Then, you can click on the green portion of the ruler to set the maximum width at that value or the purple portion of the ruler to set the minimum width at that value. When you do, a dialog box is displayed that lets you set the other value if necessary and select the style sheet you want to contain the media query.
Once you complete this dialog box, the media query is displayed in the Visual Media Queries bar. If the media query has just a max-width value, it’s displayed in green. If it has both max-width and min-width values, it’s displayed in blue. And if it has just a min-width value, it’s displayed in purple. (The media queries in the CSS Designer are also prefixed with these colors.) In the example below, the media query has both min-width and max-width values, and you can see these values at the ends of the bar (480 and 767 pixels).

Once you’ve created one or more media queries and set their styles, you can use the Visual Media Queries bar to apply the styles for a media query to the page. To do that, you just click on the bar for the media query. In the page shown below, for example, three media queries have been created and the media query with a minimum width of 480 pixels and a maximum width of 767 pixels has been selected.
You can also change the min-width and max-width values for a media query from the Visual Media Queries bar. To do that, you can drag the white resize handles that appear at the ends of the selected bar. To undo a change, press Ctrl+Z (Windows) or Cmd+Z (Mac). You can also use the context menu that’s displayed when you right-click on the bar for a media query to display the code for the query and to delete the query.

After you apply a media query by selecting its bar, you can change the document back to its full size by double-clicking in the gray area to the right of the page where it says “Double click to fit width”. If you don’t see this message, you can drag the scrubber to the left and the page will snap back to its full size. Or, you can select the Full Width option from the Window Size menu at the right side of the status bar.

**Previewing web pages on Android and iOS devices**

Dreamweaver CC now provides for previewing web pages that use a responsive design on any iOS or Android device. To use this feature, open the page you want to preview. Then, click the Device Preview icon near the right side of the status bar. Dreamweaver will generate a QR code as well as a short URL and display them in a Device Preview popup.

Next, you need to be sure that the device where you want to display the page is on the same wireless network as your desktop. You also need to be sure that JavaScript and cookies are enabled in the device’s browser. Then, you can scan the QR code with the device. When you do,
you’ll be asked to enter your Adobe ID and password and indicate that you want to display the URL. If the login is successful, the device is listed at the bottom of the Device Preview popup.

In addition, the page is displayed in your device. For example, the page that follows was displayed on an iPhone 6.

To display the page in Dreamweaver as it appears in your mobile device, you can click the Inspect to Debug icon to the right of the device name in the Device Preview popup. Then, you can make any adjusts you like to the page. When you save the changes, they’re reflected immediately in your mobile device.

You can use the short URL in the Device Preview popup to display the page in a desktop browser. To do that, just click the Copy URL to Clipboard icon to the right of the URL. Then, paste the URL into the browser’s address bar. After that, you can size the browser window to see how the page changes at different breakpoints. In addition, if you make a change to the page in Dreamweaver, it’s reflected immediately in the browser. In other words, you don’t have to refresh the browser to see the change.
Bootstrap

Previous releases of Dreamweaver provided a fluid grid layout feature that you could use to create a responsive web design that incorporated media queries with a fluid layout. Although this feature is still included in Dreamweaver CC 2015 (see the Document Type list in the New Document dialog box below), it’s considered a legacy feature. Instead of using this feature, then, you’ll want to use the new Bootstrap framework that’s integrated into Dreamweaver.

Like the fluid grid layout feature, you can use Bootstrap to create a mobile first design that consists of up to 12 columns. To create a web page using Bootstrap, you can choose the New Document category from the New Document dialog box, choose HTML for the document type, and then click the Bootstrap tab.

By default, a new style sheet will be created for the media queries and styles that are generated. If you want these media queries and styles to be added to an existing style sheet, though, you can select the Use Existing option and then identify the style sheet. You can also attach other style sheets using the Attach Style Sheet icon to the right of the Attach CSS list box.

You can also change the media queries and classes that are generated by clicking Customize to display the available options. The default is for a page to have 12 columns with 30 pixels between columns. In addition, media queries will be created for devices 768 pixels or larger, 992 pixels or larger, and 1200 pixels or larger. (Remember that when you develop a page using mobile first design, the styles for devices like mobile phones are coded outside the media queries and are used as the base styles for the page. Then, the styles in the media queries can override these styles.)
Finally, you can use the Include a Pre-built Layout option to determine if a blank document or a document with a basic Bootstrap structure is created. If you select this option, a page that looks like the one shown below is created. You can use the information on this page to help you customize the page, and you can review the HTML for the page to help you understand how the CSS classes are used to structure the page.

![Bootstrap with Dreamweaver](image)

When you create and save a Bootstrap document, three folders named css, fonts, and js are created. The fonts folder contains five glyphicons in font format that you can use in your documents. The js folder contains the Bootstrap plugin and the jQuery library in minimized format, which is used by the plugin. The css folder contains a style sheet named bootstrap.css that includes all the styles and media queries that are generated by Bootstrap. This file is read-only by default, which is usually what you want. Then, if you need to override any of its styles, you can create a new style sheet and attach it to your document after the Bootstrap style sheet.

After you create a Bootstrap document, you can use the Bootstrap Components category in the Insert panel to add components to the page. If you’re starting from a blank document, for example, you’ll want to add a Container or Container-fluid component for the main content depending on whether you want to create a fixed or fluid layout. Then, you can use the Grid row with column component to create a grid with the number of columns you specify.

You add the content for a page within the columns of the page. That content can include not only text, but any of the other components in the Bootstrap Components category of the Insert panel. That includes navigation bars, drop-down lists, input elements, buttons, labels, and glyphicons as shown in the example above, as well as other components like carousels, tabs, accordions, and breadcrumbs.
If you need to add a row to a page, you can do that by selecting the row after which you want to add the new row. When you do, the Add New Row icon appears below the row. When you click on this icon, a new row with two new columns each with six child columns is added.

You can also add a new column by selecting the column after which you want to add the new column. Then, the column you selected is duplicated.

To change the width of a column, you can drag the Resize Column handle that appears at the right side of the column when it’s selected. You can also offset a column so it appears to the right of where it would normally appear. To do that, you can drag the Offset Column handle that appears at the left side of the column when it’s selected. These skills are particularly important when you’re changing the layout of a page for different viewport sizes. Then, the changes you make are applied only to the viewport size that’s currently displayed.