Thanks for downloading this chapter from Murach’s Dreamweaver CC 2014. We hope it will show you how easy it is to learn from any Murach book, with its paired-pages presentation, its “how-to” headings, its practical examples, and its clear, concise style.

To view the full table of contents for this book, you can go to our website. From there, you can read more about this book, you can find out about any additional downloads that are available, and you can review our other books on web development.

Thanks for your interest in our books!
What developers have said about two of our related books:
*Murach’s HTML5 and CSS3* and *Murach’s JavaScript and jQuery*

“I wanted to let you know how much I enjoy your HTML5 & CSS book, all the cool things I am learning that continually have me saying ‘wow!’ It’s exactly what I need: Clear, easy-to-read, well-designed, sections handle-able, good graphics and examples, and not overly technically worded, which tends to make my artist/designer brain implode.”

Dawn Kaczor, Signart Lettering Company, Massachusetts

“The great content, the easy-to-read writing style, the unique paired-pages format, and the end-of-chapter exercises make Murach’s jQuery book a must-have addition to a web developer’s library.”

Jason Ong, ASPNET World

“Every two-page spread is designed to have all the detail about a topic on the left hand page and everything that a developer would need for reference material on the right hand page. This is a fantastic approach that I have not seen before in technical books.”

Jim O’Neil, Denver Visual Studio .NET

“Your books are so good that I threw away the assigned book for my class and bought *Murach’s JavaScript and jQuery* (which has helped restore my 4.0 GPA).”

Blaine Simcox, Computer Information Technology Student

“This HTML5 book has greatly helped my business and it is worth its weight in gold.”

Posted at an online bookseller

“I use jQuery and JavaScript every day, and I thought I knew a lot, but this book taught me more.”

Posted at an online bookseller

“An excellent source for anybody, novice or professional, looking to get started with HTML5 and CSS3. It is my go-to guide when I’m designing web pages.”

Jamie McMahon, DreamInCode.net
How to build a website with Dreamweaver

In chapter 2, you learned how HTML and CSS are used to build web pages. Now, you’ll learn how to build web pages with Dreamweaver and have it generate the HTML and CSS code for you.

How to create a site and add a web page .........................76
How to create a Dreamweaver site ......................................76
How to create a new web page ...........................................78
How to define the basic appearance of a web page ..................80
How to add content to a web page ......................................82

How to work with HTML in Dreamweaver .......................84
How to use the Property Inspector to work with HTML ............84
How to use the Insert panel to work with HTML ...................86
How to use the Insert panel to add structural elements ..........88

How to work with CSS in Dreamweaver ............................90
How to use the CSS Designer to create style rules and styles .........90
How to use the CSS Designer to modify, add, and delete styles ....92
How to use the Property Inspector to display and modify styles ..94
How to use Element Live Display to work with classes and IDs ......96

How to work with external style sheets ..........................98
How to create an external style sheet ................................98
How to move style rules and copy styles ..............................100
How to attach an external style sheet to a web page .................102
How to create a style sheet for printing ............................104

Other skills for working with Dreamweaver sites .............106
How to validate a web page .............................................106
How to set browser preferences .......................................108
How to delete, edit, and duplicate sites ..............................110

Perspective ......................................................................112
How to create a site and add a web page

When you use Dreamweaver to develop a website, you typically start by creating a Dreamweaver site that will contain all the files for the website. Then, you can add pages to the site, define the basic appearance of each page, and add content to each page.

How to create a Dreamweaver site

In chapter 1, you learned how to create a Dreamweaver site. Figure 3-1 presents this information again so you can see how it’s used to create the site for this chapter.

First, because each site must have a unique name, I included the chapter number in the site name. Then, I stored the websites for each chapter in a folder with a name that identifies the chapter number. Finally, although you can’t see it here, I stored each website for a chapter in a separate folder within the chapter folder. For example, the application that you’ll see in figure 3-4 is stored in a folder named 3-04 in the chapter03 folder.

When you create a site, Dreamweaver establishes a reference between that site and the folder you specify. If that folder contains other folders and files, they’re automatically included in the site. However, you can also create a site from scratch. To do that, just specify a folder that doesn’t already exist. Then, Dreamweaver creates that folder, and you can add any folders and files you want to that site. In the next figure, for example, you’ll learn how to add a file that defines a web page to a site.
The Site Setup dialog box

How to create a new Dreamweaver site

1. Choose Site → New Site to display the Site Setup dialog box.
2. Enter a name for the site into the Site Name text box.
3. Click the folder icon to the right of the Local Site Folder text box, and then browse to and select the top-level folder for the site. Or, enter the path for this folder into the text box.
4. Click the Save button to create the new site.

Description

- Although you can use Dreamweaver to work with individual files, you typically define a site for each website that contains the folders and files for that website. Then, you can use Dreamweaver’s features for working with sites as you develop and maintain the website.
- If you create a site for a folder that already contains folders and files, those folders and files are included in the site.
- If you create a site for a folder that doesn’t exist, that folder is created. Then, you can add any folders and files you need.
- After you create a Dreamweaver site, you can use the first menu at the top of the Files panel to display it if another site is currently displayed.
How to create a new web page

Figure 3-2 presents the New Document dialog box that you can use to add a variety of page types. To add a basic HTML page, you choose the Blank Page category and then select HTML for the page type and <none> for the layout. You can also select a document type using the DocType menu. In most cases, though, you’ll use the default of HTML5.

Finally, if your site already contains one or more external style sheets, you can attach those style sheets by clicking the Attach Style Sheet icon and then identifying each style sheet you want to attach. If you don’t do that, you can attach style sheets using the CSS Designer as described later in this chapter.

Note that when you create a page using this technique, a default name like Untitled-1 is used for the page. In addition, the page isn’t saved in the site. Because of that, you’ll want to save the file right after you create it.

You’ll also want to save the files you’re working on frequently as you use Dreamweaver. That’s because Dreamweaver doesn’t automatically save your work at given intervals like many other software programs do.

When you create an HTML document as shown here, it includes the basic elements that you learned about in chapter 2. To start, it includes a DOCTYPE declaration that indicates that the document is going to use HTML5. In addition, it includes an html element for the document tree. Within this element is a head element and a body element. And within the head element is a meta element and a title element with a default title. If you attach a CSS file when you create the page, a link element that identifies that file is also included in the head element.

If you just want to create a basic page with the settings shown here, you can do that without displaying the New Document dialog box. To do that, just right-click on the folder in the Files panel where you want to add the page and select New File from the shortcut menu that’s displayed. Then, enter a name for the page in the Files panel. Note that when you use this technique, the page is automatically saved in the site.

Instead of creating a web page from scratch, you should know that you can also create a page from another page. To do that, just select the existing page in the Files panel and then choose File→Save As to save the page with a different name. This can be helpful if you want to create a new page that’s similar to an existing page.
The New Document dialog box

How to create a new HTML5 document

- Choose File→New to display the New Document dialog box.
- To create a document with basic starting code, choose the Blank Page category, make sure the HTML page type is selected, and choose <none> for the layout.
- Click the Create button to create the new document.
- Save your page by choosing File→Save As or by clicking the Save button in the Standard toolbar to display the Save As dialog box. Then, select the location where you want to save the file, enter a name for the file, and click the Save button.
- You can also choose File→Save As to create a new page from the page you select in the Files panel.
- To quickly create a new, blank page, right-click on the folder where you want to add the page in the Files panel, select New File, and enter a name for the file.

Description

- When you create a web page with Dreamweaver, the page uses HTML5 by default.
- If the site that will contain the new page includes external style sheets, you can attach them by clicking on the Attach Style Sheet icon (🔗).
- In addition to creating a web page with basic starting code, you can create pages with 2- and 3-column layouts. Because the code that’s generated for these layouts is cumbersome, though, we recommend that you don’t use them.
- If the Standard toolbar isn’t displayed, you can display it by right-clicking the Document toolbar and choosing Standard or by choosing View→Toolbars→Standard.
How to define the basic appearance of a web page

Before you start adding content to a page, you may want to set some properties that define the basic appearance of the page. To do that, you can use the Page Properties dialog box shown in figure 3-3. As you can see, the page properties are divided into several categories. The three categories you’re most likely to use are Appearance (CSS), Links (CSS), and Headings (CSS).

In this figure, you can see the properties that are available from the Appearance (CSS) category. Here, the font, font size, background color, and margins for the page have been set. In addition to these properties, you can set other font properties, the text color, and properties for background images.

From the Links (CSS) category, you can set properties that define the appearance of the links on the page. That includes the font and font size and the colors of the links in various states. It also includes when links are underlined.

From the Headings (CSS) category, you can define the appearance of the six levels of headings. That includes the font that’s used for all headings, as well as the font size and color for each heading.

Although the Page Properties dialog box makes it easy to define the basic appearance of a web page, you should realize that the properties you specify here are included in an embedded style sheet. Because of that, you’ll typically want to move the CSS rule sets that contain these properties to an external style sheet as described later in this chapter. Or, you can use the CSS Designer to create the rule sets you need in an external style sheet. You’ll learn how to do that later in this chapter too, and you’ll learn more about the properties that you can use with text and links in chapter 5.
The Appearance (CSS) category of the Page Properties dialog box

Categories of the Page Properties dialog box

<table>
<thead>
<tr>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance (CSS)</td>
<td>CSS styles for fonts, backgrounds, and margins.</td>
</tr>
<tr>
<td>Appearance (HTML)</td>
<td>HTML attributes for backgrounds, text, links, and margins. You should avoid using this category because it results in invalid HTML5 code.</td>
</tr>
<tr>
<td>Links (CSS)</td>
<td>CSS styles for links, including those for fonts, link states, and underline style.</td>
</tr>
<tr>
<td>Headings (CSS)</td>
<td>CSS styles for headings, including fonts, sizes, and colors for heading levels 1 through 6.</td>
</tr>
<tr>
<td>Title/Encoding</td>
<td>The title for the document, as well as the document type (usually HTML5) and encoding (usually UTF-8).</td>
</tr>
<tr>
<td>Tracing Image</td>
<td>An image that you can use as a guide for designing a page.</td>
</tr>
</tbody>
</table>

Description

- You can use the Page Properties dialog box to set the basic properties for a page. Then, you can use CSS to apply formatting to individual elements.
- To display the Page Properties dialog box, choose Modify → Page Properties or click the Page Properties button in the Property Inspector.
- The CSS properties you specify from the Page Properties dialog box are included in an embedded style sheet. Then, you can move the CSS rule sets that contain these properties to an external style sheet as described later in this chapter.
- If you prefer, you can use the CSS Designer as shown later in this chapter to create the CSS rule sets for a page in an external style sheet.
- Instead of entering the title for a page from the Title/Encoding category, you can enter it in the Title text box in the Document toolbar.
How to add content to a web page

The easiest way to add content to a web page is to place your cursor within the page and begin typing. If you do that, you should know that you can press the Enter or Return key to create a paragraph for the text you’re currently typing and to start a new paragraph. In other words, the text is structured with <p> elements. You can also enter a line break (a br element) by holding down the Shift key and pressing the Enter or Return key.

Often, though, the content is provided to you in the form of one or more files. If the content is plain text, you can add it to a web page by copying it from the original file and pasting it into the page. Note that if you use this technique, any text that’s separated by two line breaks is formatted as paragraphs. Also note that you can copy content from the original file by opening it outside of Dreamweaver, or you can add the file to the site and then open it in Dreamweaver. In figure 3-4, for example, a text file named welcome.txt has been added to the site, and the content of this file has been added to the page.

Three images have also been added to the page in this figure. (You can only see the first two here.) These images have been added to the images folder of the website. Then, you can add an image to the page by dragging it from the Files panel and dropping it on the page where you want it to appear.

Of course, there are other ways that you can add text and images to a page. You’ll learn more about that in the next chapter. For now, though, you can use the techniques shown here to quickly add the text and images you need.
How to add plain text to a web page

- Open the file that contains the text, select the text you want to copy, and click the Copy button in the Standard toolbar or press Ctrl+C (Windows) or Cmd+C (Mac).
- Position the cursor where you want to add the text in Dreamweaver, and click the Paste button in the Standard toolbar or press Ctrl+V (Windows) or Cmd+V (Mac). Portions of text that are separated by two line breaks are formatted as paragraphs.
- You can also enter text directly into the Document window. When you do that, you can press the Enter key (Windows) or Return key (Mac) to start a new paragraph and Shift+Enter (Windows) or Shift+Return (Mac) to start a new line.

How to add an image to a web page

- Drag the image from the Files panel to the location in the page where you want the image to appear and then drop it.

Description

- The text for the web pages you develop will often be written for you by someone else. Then, you can copy the text from a file inside or outside of Dreamweaver, and paste it into a page within Dreamweaver.
How to work with HTML in Dreamweaver

In this topic, you’ll learn how to use the HTML Property Inspector and the Insert panel to work with the HTML in a web page.

How to use the Property Inspector to work with HTML

Figure 3-5 shows a web page after two paragraphs have been formatted as headings. To create these headings, I started by clicking in the paragraph to place the cursor in that paragraph. Then, I selected the Heading 2 option from the Format menu in the Property Inspector. When I did that, the <p> element was changed to an h2 element.

The other controls in the Property Inspector also generate HTML code for you. For example, you can add an id or class attribute to the element that contains the cursor by entering it in the ID or Class combo box.

In addition to formatting the element that contains the cursor, you can use the Property Inspector to format selected text or one or more selected elements. To enclose text with a <strong> or <em> element, for example, you drag over the text in the Document window and then click the Bold or Italic icon. And to generate HTML that formats elements as a list, you drag over the elements in the Document window and then click the Unordered List or Ordered List icon. To format a single element, you can drag over it or you can click in it and then click on its tag in the Tag selector at the bottom of the Document window.

The properties that are available in the Property Inspector change depending on what’s selected in the Document window, and you’ll learn more about these properties as you progress through this book. For now, you just need to understand the basic skills for using the HTML Property Inspector.

By the way, you should notice that the HTML category of the Property Inspector is displayed in this figure, as indicated by the HTML button on the left of the Inspector. That’s why we refer to this view of the Inspector as the HTML Property Inspector. In contrast, the CSS category provides for formatting a page using CSS, and you’ll see how that works later in this chapter.
The Property Inspector when the HTML option is selected

Description

- The *HTML Property Inspector* applies basic formatting to a page by generating HTML code based on the selections you make. To turn the HTML version of the Inspector on, click the HTML button on the left of the Inspector.

- To use the HTML Property Inspector to format an element, place the cursor in the element in the Document window and then use the controls that are displayed. For example, to change a `<p>` element to a heading element, you place the cursor in the element and then select a heading level from the Format menu.

- You can also use the HTML Property Inspector to format the text for all or part of an element or for two or more elements. To do that, you must select the text in the Document window.

- The formatting that’s available from the Property Inspector depends on the element that’s selected.

Figure 3-5 How to use the Property Inspector to work with HTML
How to use the Insert panel to work with HTML

As you develop a web page, you’ll need to work with many different types of objects. One way to do that is to use the Insert panel shown in figure 3-6. This panel groups the available objects into several categories. You can see the objects in the Structure category here, but you’ll want to review the objects in the other categories so you know what’s available.

You can use the Insert panel to format existing content or insert new objects. To format existing content, you select the content in the Document window and then select an object from the Insert panel. For example, instead of using the Property Inspector to change a paragraph to a heading, you can click in the paragraph and then select a heading from the Heading menu in the Insert panel.

As another example, suppose you want to format two or more paragraphs as a bulleted list. To do that, you can just select those paragraphs in the Document window and then click the Unordered List object in the Insert panel. You’ll learn more about lists and how to format them in chapter 6.

You can also use the Insert panel to add new objects. To do that, you position the cursor in the Document window where you want the element added and select the object from the Insert panel. Then, if no additional information is needed to insert the object, the HTML for the object is added to the document along with a placeholder that indicates where the object was inserted. If you insert a heading, for example, the placeholder consists of text that indicates where to place the content for the heading. Then, you can replace this text with the text for the heading.

In some cases, a dialog box will be displayed when you insert an object so you can enter information about the object. If you insert an image, for example, a dialog box is displayed that lets you select the image you want to insert. In most cases, that’s what you want. If not, you can turn off the Dreamweaver preference that controls the display of these dialog boxes as described in this figure. Then, you can use the Property Inspector to specify the required information.

A dialog box is also displayed if you insert a div element or one of the HTML5 semantic elements. You’ll learn more about how that works next.
The page as a new section is being inserted

![Image showing the Insert panel in Dreamweaver]

Description

- You can use the **Insert panel** to insert and apply HTML elements.
- To display the objects for a category of HTML elements, select the category from the menu at the top of the Insert panel.
- To insert the HTML for most objects, you can click in the Document window where you want to insert an object and then click the object in the Insert panel. Or, you can drag the object from the Insert panel and drop it in the Document window.
- To change the HTML element for existing content, select the item and then click an object in the Insert panel.
- To insert some objects, you select an item from a menu within a category. To insert an h3 element, for example, you use the Heading menu in the Structure category.
- By default, Dreamweaver displays a dialog box when you insert some objects so you can provide information about that object. If that’s not what you want, you can remove the check mark from the Show Dialog When Inserting Objects option in the General category of the Preferences dialog box (Edit ➔ Preferences). Then, you can use the Property Inspector to specify the required properties.
- In figure 3-7, you can learn about the special techniques that are required when you insert structural elements like the HTML5 semantic elements.

Figure 3-6  How to use the Insert panel to work with HTML
How to use the Insert panel to add structural elements

In the last topic, you learned the basic techniques for using the Insert panel to add HTML elements. Now, you’ll learn about some special techniques for adding structural elements like the HTML5 semantic elements. The techniques you use depend on whether you’re working in Design view, Live view, or Code view. Figure 3-7 presents the techniques for each of these views.

When you insert a structural element in Design view, a dialog box like the one shown at the top of this figure is displayed. The Insert menu in this dialog box lets you select where you want the element inserted. Although the options that are available vary, the standard options are At Insertion Point, After Start of Tag, and Before End of Tag. If the document contains one or more tags with id attributes, Before Tag and After Tag options are also available. Then, if you select one of the Tag options, a second menu becomes available that lets you select the tag. In this figure, a section will be inserted after the section with an id of “welcome”.

You can also enclose existing content in a div element or an HTML5 semantic element. To do that, just select the content in the Document window before you select an object from the Insert panel. Then, the Insert menu in the dialog box that’s displayed includes a Wrap Around Selection option that causes the selected content to be placed inside the inserted element.

Because it can be difficult to insert structural elements in the correct location when you use Design view, you may want to use Live view or Code view instead. To insert an element in Live view, you start by selecting the element relative to which the new element will be inserted. Then, when you insert the new element, the four icons shown in the second example in this figure are displayed. The first two icons let you insert the new element before or after the selected element. The third icon lets you wrap the new element around the selected element. And the fourth icon lets you nest the new element within the selected element.

Note that you don’t have to identify elements by ID when you work in Live view like you do sometimes in Design view. However, you can’t assign an ID or class to a structural element when you create it in Live view like you can in Design view. Instead, you have to use the Property Inspector or Element Live Display to assign an ID or class to an element after you create it.

If you want to have complete control over where an element is added, you can insert it in Code view. To do that, you simply position the cursor where you want to insert the element and then click on the element in the Insert panel. When you do, the Insert dialog box is displayed just like it is when you work in Design view. In this case, though, you can just select the default option to insert the element at the insertion point.

You can also wrap a new element around existing content in Code view. To do that, just select the content before you insert the element. Then, the default option in the dialog box that’s displayed will be to wrap the element around the selected content.
The Insert dialog box that's displayed in Design view and Code view

![Insert Section Dialog Box]

The icons that are displayed in Live view

![Live View Icons]

How to insert elements in Design view

- When you insert a div or an HTML5 structural element in Design view, Dreamweaver displays a dialog box that lets you choose where to place the element.
- By default, the options in the Insert menu let you insert an element at the insertion point, after the start of a tag, or before the end of a tag. You can use the after and before options with the body element or any element that has an ID.
- If any elements in the document have IDs, options that let you insert an element before or after those elements are also available.
- If content is selected in the Document window when you insert one of these elements, an option is available that lets you wrap the element around the selection.

How to insert elements in Live view

- When you insert a div or an HTML5 structural element in Live view, Dreamweaver displays icons that let you insert the element before the selected element, insert the element after the selected element, wrap the element around the selected element, or nest the element within the selected element.

How to insert elements in Code view

- Position the cursor where you want to insert the element and click on the element in the Insert panel. When the Insert dialog box is displayed, accept the default “At insertion point” option.
- You can also select content before you insert an element and then accept the default “Wrap around selection” option to wrap the new element around the selection.

Figure 3-7 How to use the Insert panel to add structural elements
How to work with CSS in Dreamweaver

When you work with Dreamweaver, you need to know that Dreamweaver typically refers to CSS rule sets as *style rules* and CSS rules as *styles*. Because of that, I’ll use those terms from now on. The topics that follow show you how to create, modify, and delete style rules and styles.

How to use the CSS Designer to create style rules and styles

Figure 3-8 shows how to create a style rule with the *CSS Designer*. To start, if you need to create an external or embedded style sheet, you can use the first procedure in this figure.

Then, to add a style rule to an external style sheet, you select the style sheet from the Sources pane. Or, if you’re using an embedded style sheet, you select `<style>` from this pane. This is a critical step when you create a style rule because you can accidentally add a style rule to the wrong style sheet if you forget to select the one you want.

To add a style rule to the selected style sheet, you click the Add Selector icon at the top of the Selectors pane. Then, a selector is displayed for the element that’s selected in the Document window. If that’s the selector you want to add, just press the Enter or Return key. Otherwise, enter the selector you want and press Enter or Return.

When you click the Add Selector icon, the selector for the current element often includes one or more parent elements. For example, if you selected the first heading element in the document in this figure, the selector would look like this:

```
body section h2
```

If you don’t want to include the parent elements, you can omit them one at a time by pressing the Up Arrow key. In this example, the first time you pressed the Up Arrow key, the body element would be omitted from the selector. The second time you pressed this key, the section element would be omitted. This can make it easier to work with complex selectors.

If necessary, you can also add parent elements that you’ve omitted back to a selector. To do that, you press the Down Arrow key. Then, the parent elements are added back in the reverse order that they were omitted.

After you add the selector, you can add styles to the style rule by using the Properties pane of the CSS Designer. In this figure, for example, you can see that I’ve set the font-family, font-size, and line-height properties for the body element. (These properties are displayed in bold.) In the next figure, you’ll learn how to work with the Properties pane.
A page after styles have been added for the body element

How to create a style sheet
- Click the Add CSS Source (+) icon in the Sources pane and select Create a New CSS File to create an external style sheet or select Define in Page to embed the styles in the page.

How to create a style rule and add styles
1. Select the name of the style sheet you want to add the style to from the Sources pane of the CSS Designer. To add the style to an embedded style sheet, select <style>. This is a critical step because it determines where the style rule is added.
2. Click the Add Selector (+) icon in the Selectors pane and enter a selector in the box that’s displayed. By default, the box will contain a selector for the element that’s selected in the Document window, but you can modify that.
3. Use the Properties pane to set the styles for the selector. This pane lets you set all of the properties that apply to the element or elements that are selected.

Notes
- In Dreamweaver, a CSS rule set is often referred to as a style rule, and a rule is referred to as a style.
- You can use the Up Arrow key to omit parent elements from a selector when you create it, and you can use the Down Arrow key to add omitted elements back.
How to use the CSS Designer to modify, add, and delete styles

Figure 3-9 shows how you can use the CSS Designer to modify, add, and delete styles. This assumes that the style rule has already been created. Then, you start by selecting the style rule.

To display the styles for a style rule, you select its style sheet from the Sources pane and its selector from the Selectors pane. In figure 3-9, for example, you can see the properties for the body element in the external style sheet named styles.css. Notice here that the Show Set option at the top of the Properties pane is checked. That way, only the properties that have been set are displayed.

To modify a property, you change its value in the Properties pane. To do that, you can use the icons at the top of this pane to scroll to the properties in five different categories: Layout, Text, Border, Background, and Custom. Note that only the Layout and Background icons are shown here because these are the only categories that contain properties that have been set. If you look back to figure 3-8, though, you can see the icons for all five categories.

Later, if you want to disable or delete a style, you use the icons that appear when you point to the property. In this example, you can see these icons to the right of the padding property. If you click the Remove icon, the style is deleted from the style rule. If you click the Disable icon, the property is commented out in the style sheet. Then, if you ever want to enable the property, you just click this icon again.

If you decide that you don’t want to keep the changes that you’ve made to one or more properties, you can choose Edit→Undo or use the shortcut key for your system to reverse the changes. With previous releases of Dreamweaver CC, you couldn’t do that. Instead, you had to display the code for the style sheet, move the focus to that code, and then undo the change.

In chapter 2, you learned that the formatting that’s applied to an element can be overridden by other elements that it contains. To explain how this works, consider the font-family property that’s shown in this figure for the body element. Unless this property is overridden, it will be inherited by all text elements in the body of the document. If that’s not what you want, you can change this property for specific elements.

When you display the properties for a specific selector in the Properties pane, only the properties that are applied directly by that selector are listed. But you can also display the properties that an element inherits from any containing elements. To do that, just select the element in the Document window and then select the COMPUTED option in the Selectors pane. Then, all the properties that apply to that element are displayed.

As you work with the CSS Designer, you should know that you can collapse individual panes by clicking on the header for the pane. Then, the item that’s currently selected in that pane will be displayed in the header along with the name of the pane. This is particularly useful with the Sources pane. If I collapsed the Sources pane shown in this figure, for example, the header would look like this:

Sources: styles.css
How to display the styles for a style rule

- Select the style sheet in the Sources pane, and select the selector in the Selectors pane. Then, the styles are displayed in the Properties pane.
- To display the properties in a specific category, click on the appropriate icon at the top of the Properties pane.
- To display just the properties that have been set, check the Show Set box.

How to modify, add, comment out, or delete a style in a style rule

- To modify a style, select it in the Properties pane and change its value.
- To add a new style, find the property in the Properties pane and set its value.
- To comment out or remove a property from a style sheet, point to the property in the Properties pane and click on the Disable or Remove icon that appears.
- To reverse a change, choose Edit → Undo or use the keyboard shortcut.

How to display all of the styles for a selected element

- Select the element in the Document window, and select the COMPUTED option in the Selectors pane. Then, the Properties window includes the properties that have been inherited from containing elements.

Description

- The Properties pane lets you set all of the properties that apply to the selected element or elements without writing any CSS code.

Figure 3-9  How to use the CSS Designer to modify, add, and delete styles
This can keep you from inadvertently selecting the wrong style sheet as you apply styles. Then, when you need to select a different style sheet, you can click the header again to expand the pane.

**How to use the Property Inspector to display and modify styles**

Although you’re most likely to use the CSS Designer to work with styles as described in the previous figure, you can also use the CSS Property Inspector to work with some of the most common styles for an element. Figure 3-10 shows you how.

To start, you click the CSS icon at the left side of this panel to display the controls for working with CSS. Then, you select the style rule whose properties you want to display from the Targeted Rule combo box. Then, the properties for that style rule are displayed and you can modify them any way you like.

It’s important to note that the properties that are available in the Property Inspector vary depending on the style rule that you select. In this example, the text-based properties are available because the style rule for the body element is selected. You’ll learn more about the properties that are available for different types of objects as you proceed through this book.

In addition to modifying styles, you can use the Property Inspector to add a class attribute to an element. You can also remove a class from an element, and you can add multiple classes.

Finally, you can use the Property Inspector to add inline styles to an element. Since inline styles aren’t a practical way to format elements, though, you probably won’t use them.
**Procedures**

- To display the CSS Property Inspector, click the CSS icon in the Properties pane.
- To display the styles for a style rule, select the rule from the Cascade category of the Targeted Rule combo box.
- To set or modify the styles for a selected style rule, use the controls in the Property Inspector.
- To apply a class to a selected element, select that class from the Apply Class category of the Targeted Rule combo box. To remove a class from a selected element, select the `<Remove Class>` option. And to apply multiple classes to a selected element, select the Apply Multiple Classes option and then select the classes from the dialog box that’s displayed.
- To display the CSS Designer for a style rule, click the CSS Designer button. To display the Page Properties dialog box, click the Page Properties button. And to display the classic CSS Rule editor, click the Edit Rule button.

**Description**

- The *CSS Property Inspector* lets you apply basic formatting to a page by generating CSS based on the selections you make.
How to use Element Live Display to work with classes and IDs

One of the new features of Live view in Dreamweaver CC 2014 is *Element Live Display*. This display lets you work with the classes and ID of the selected element using a simple interface. Figure 3-11 shows how Element Live Display works.

In the example in this figure, a section element with an ID of “solutions” was selected by clicking on it in the Tag selector. Then, the Element Live Display showed the name of the element along with its ID. If an ID hasn’t been assigned to an element, though, you can assign one by clicking the Add Class/ID icon and then entering the ID in the space that’s provided. When you do that, be sure to prefix the ID with a pound sign (#) just like you do in the selector for an ID.

You can use the same technique to assign a class to an element. In this case, though, you must precede the class name with a period. In addition, if one or more classes already exist when you enter the period, a class list is displayed as shown in the first example in this figure. Then, you can select one of these classes to assign it to the element.

You can also use Element Live Display to remove an ID or class from an element. To do that, just point to the right side of the box for the ID or class. When you do, a Remove Class/ID icon will appear as shown in the second example. Then, you can click this icon to remove the class or ID.
An Element Live Display with a class list displayed

How to add a class or ID

- Click the Add Class/ID icon (+) at the right side of the Element Live Display. Then, enter the class or ID in the space that’s provided. A class name must be preceded by a period, and an ID must be preceded by a pound sign (#).
- If one or more classes already exist, a class list is displayed when you enter a period. Then, you can select a class to assign it to the element.

How to remove a class or ID

- To remove a class or ID, point to the right side of the box that contains the class or ID and click the Remove Class/ID icon (x) that’s displayed.

Description

- When you select an element in Live view, an Element Live Display is displayed above that element. This display includes the element name, along with the ID and classes assigned to the element, if any.
- You can use Element Live Display to add and remove classes and IDs.

Figure 3-11  How to use Element Live Display to work with classes and IDs
How to work with external style sheets

In figure 3-7, you learned the basics of how to create a style sheet. Now, you’ll learn more about creating and working with external style sheets.

How to create an external style sheet

Figure 3-12 shows how to create an external style sheet. After you click on the plus icon in the Sources pane of the CSS Designer, you select Create a New CSS File. That will display the dialog box shown at the top of this figure.

In this dialog box, you can enter a name for the CSS file. In addition, you can identify a folder within the website where you want to store the file. In this example, I didn’t specify a location, so the file will be stored in the root folder for the site. However, CSS files are typically stored in a folder named styles within the root folder.

By default, a link element is added to the head element of a document when you create a new CSS file. It will attach the file to the document. For example, the link element that’s generated for the file in this figure will look like this:

```html
<link href="styles.css" rel="stylesheet" type="text/css">
```

Remember, though, that the type attribute isn’t required for HTML5.

You can also use the Create a New CSS File dialog box to specify a condition under which a style sheet is used. For example, you may want the style sheet to be applied only when a page is being printed. You’ll learn more about that later in this chapter.

After you create a style sheet, it will appear in the Sources pane of the CSS Designer. Then, you can select it to add style rules to it. If more than one style sheet is associated with a document, you can also click the ALL SOURCES option in the Sources pane to display all the selectors in all the style sheets.
Chapter 3      How to build a website with Dreamweaver

The Create a New CSS File dialog box

An external style sheet in the CSS Designer

How to create an external style sheet using the CSS Designer

1. Click the Add CSS Source (+) icon in the Sources pane and select Create a New CSS File to display the dialog box shown above.

2. Enter the name of the file in the File/URL text box to add it to the root folder of the website, and click OK. Or, click the Browse button, select a location from the Save Style Sheet As dialog box that’s displayed, enter the name of the file in the File Name text box, and click Save.

Description

- When you create an external style sheet with the Link option selected, a link element that identifies the style sheet is added to the head element of the document.

- If a document is associated with more than one style sheet, you can click the ALL SOURCES option in the Sources pane to display the selectors in all the style sheets.

- External style sheets are often stored in a separate folder of a website. To add a folder, right-click on the folder that will contain it, select New Folder from the menu that’s displayed, and then enter a name for the folder.

- Because an external style sheet separates the formatting (CSS) from the content (HTML), we recommend that you use them for all production applications. External style sheets can also be attached to more than one web page.
How to move style rules and copy styles

As you create the style rules for a document, you may decide that you want to store one or more of them in a style sheet other than the one where they were originally created. In that case, you can use the procedure in figure 3-13 to move the style rules from one style sheet to another.

This is particularly useful if you start to format a document by using an embedded style sheet and then later decide that you want to store the style rules in an external style sheet. It’s also useful if you have two or more external style sheets attached to a document and you want to move styles between those style sheets.

After you move style rules from one style sheet to another, you may want to remove a style sheet from the Sources pane as described in this figure. Note, however, that this doesn’t delete the CSS file for the style sheet. As a result, you can still attach it to your web pages.

In addition to moving style rules from one style sheet to another, you can copy styles from one style rule to another. To do that, you use the shortcut menu that’s displayed when you right-click a selector in the Selectors pane. You can use this menu to copy all the styles in a style rule or just the styles in a specific category, such as layout styles or text styles. Then, you can right-click on another selector and choose Paste Styles to paste the copied styles to the style rule for that selector. This is useful if you need to include similar styles in two or more style rules. After you copy the styles, of course, you can change them any way you want.
An embedded style rule as it’s being moved to an external style sheet

The shortcut menu for copying styles

How to move style rules
1. Select the style sheet that contains the style rules you want to move in the Sources pane of the CSS Designer to display the selectors it contains in the Selectors pane.
2. Select the selectors you want to move to another style sheet and then drag and drop them onto that style sheet in the Sources pane.

How to copy styles
1. Right-click the selector whose style rules you want to copy in the Selectors pane, and choose Copy All Styles to copy all the styles, or choose an item from the Copy Styles submenu to copy a specific type of style.
2. Right-click the selector where you want to copy the styles and choose Paste Styles.

Description
- You can use the first procedure shown above to move style rules from any style sheet to any other style sheet.
- If you move all of the style rules in a style sheet to another style sheet, you can remove the style sheet from the Sources pane by selecting it and then clicking the Remove CSS Source icon (−). Note that this doesn’t delete the style sheet.
- You can use the second procedure shown above to copy styles from one style rule to another.
How to attach an external style sheet to a web page

Figure 3-14 shows two ways to attach an external style sheet to a web page. If you use the CSS Designer, you can use the dialog box to identify the style sheet that you want to attach and set conditions for using the style sheet. If you use the drag-and-drop method, you can’t specify any options. Either way a link element is added to the head section of the HTML document.

When you use the CSS Designer to attach an external style sheet, though, the link element is added after any other link elements. Because of that, you may need to change the order of the link elements. If, for example, you attach the normalize.css style sheet to a web page that you’ve built, its link element will come last, even though it is supposed to come first. Unfortunately, the only way to change the order of link elements is to work in Code view.

Before you attach a style sheet like the normalize.css style sheet, you may want to add it to the website. However, that isn’t a requirement. Instead, if you’ve already downloaded it to another location, you can use the dialog box to locate it. Then, when you click OK, Dreamweaver will display a message that asks if you want to copy the file to your site. In almost all cases, that’s what you’ll want to do.
The Attach Existing CSS File dialog box

How to attach an external style sheet to a web page

1. Choose Attach Existing CSS File from the Add CSS Source menu (➕) in the Sources pane to display the Attach Existing CSS File dialog box.

2. Click the Browse button and then locate and select the CSS file you want to attach. The file you select will be displayed in the File/URL text box.

3. Make sure the Link option is selected, and then click OK to attach the style sheet. This adds a link element for the style sheet to the head element of the HTML after any other link elements for the page.

How to use drag-and-drop to attach an external style sheet

- Switch to Code view for the HTML document. Then, drag the external file sheet from the Files panel and drop it in its proper place in the head element of the HTML. This adds a link element for the style sheet in that location.

Description

- If you want to use an existing style sheet for a website, you can add the style sheet to the website and attach it to each page that uses it.

- When you use the CSS Designer to attach a style sheet, its link element is added after any other link elements. Then, if you want to change the sequence of the link elements, you can use Code view.

- If you use the normalize.css style sheet for a page, the link element for this style sheet should be placed before any other link elements.
How to create a style sheet for printing

If you develop a web page that users are likely to print, you may want to create a separate style sheet that will be applied to the page when it’s printed. To do that, you can use the procedure in figure 3-15. Here, you start by creating a style sheet just as you would any other style sheet. Then, you indicate that the style sheet should be used only if the page is printed by selecting the Media and Print options from the two menus in the Conditional Usage (Optional) section of the Create a New CSS File dialog box.

When you’re done, a link element like the one shown in this figure is added to the document. Here, the media attribute tells the browser that the style sheet should only be used if the page is printed.

This figure also presents some basic recommendations for formatting printed pages. As you can see, the first three recommendations have to do with changing the fonts so they’re more readable. In particular, a serif font should be used for text because that makes the printed text easier to read (although sans-serif text is more readable on the screen).

The fourth recommendation is to remove site navigation. That makes sense because navigation can’t be used when the page is printed. You may, however, want to print links that link to other topics to show the reader what is available.

The last recommendation is to remove any images that aren’t needed for the printed version of the page. To remove an element, you can set its display property to “none”.
The Vecta Corp website page of figure 2-1 after it's formatted for printing

WELCOME
With innovative approaches and advanced methodologies, Vecta Corporation provides scalable business solutions to help companies achieve success through revenue increase, cost management, and user satisfaction. Our approach stems from three most important business growth aspects: helping companies reach prospects, assist in converting prospects to customers, and assist in retaining those customers. This is accomplished through our interactive solutions and expertise in providing a memorable and positive user experience.

OUR SOLUTIONS

vProspect 2.0
Define and research your target audience, define your strategy to reach that audience and present a strong and memorable brand to that audience.

vConvert 2.0
Create a highly user-friendly and easy-to-navigate information architecture that will help your prospects interact with the company on a highly interactive level.

vRetain 1.0
Build on existing customer relationships to improve productivity and maximize customer loyalty, while growing revenues.

The link element for the printing style sheet

```html
<link href="styles/print.css" rel="stylesheet" type="text/css" media="print">
```

How to create a style sheet for printing

1. Create a new style sheet, but in the Create a New CSS File dialog box, expand the Conditional Usage (Optional) section. Then, select Media from the first menu, select Print from the second menu, and click OK.

2. Set the styles for printing by selecting the print style sheet in the Sources pane and adding the required styles.

Recommendations for formatting printed pages

- Change the text color to black and the background color to white.
- Change text other than headings to a serif font to make the text easier to read when printed.
- Use a base font size that’s easy to read when printed.
- Remove site navigation since it can’t be used from a printed page.
- Remove any unnecessary images, particularly Flash and animated images.

Description

- When you create a style sheet for printing, a link element is added to the head element for the page and its media attribute is set to “print”.
- If you don’t want an element to be included when a page is printed, you can set its display property to “none”. Then, no space is allocated for the element.
- To see what a page will look like when it’s printed, display the page in a browser and select the File → Print Preview command. (In Chrome, click the Customize button and then select Print.)

Figure 3-15 How to create a style sheet for printing
Other skills for working with Dreamweaver sites

In the last three topics of this chapter, you’ll learn some other skills for working with Dreamweaver sites. Specifically, you’ll learn how to validate a web page, how to set browser preferences, and how to delete, edit, and duplicate sites.

How to validate a web page

To validate a web page, you use a program or website for that purpose. When you use Dreamweaver, for example, the page is validated using the W3C Markup Validation Service. Figure 3-16 describes how this works.

When you run a validation scan for a page from Dreamweaver, Dreamweaver sends the page to the W3C Markup Validation Service. Then, if any errors are detected, they’re returned to Dreamweaver and displayed in the Validation panel. In this figure, for example, you can see that the validation service detected three errors. In contrast, if no errors are detected, a single line is displayed in the Validation panel to indicate that.

In this example, I forced the three errors to occur by omitting the closing tag for the header element. The first error indicates that the footer element is contained within the header element. The second error indicates that the closing tag for an element contained within the main element (in this case, the header element) wasn’t found before the closing tag for the main element. And the third error indicates that the header element isn’t closed.

Notice that the line number where each error occurs is included in the Validation panel. That makes it easier to locate the errors. In addition, if you double-click on an error in the Validation panel, Dreamweaver will display the page in Split view and place the cursor in the line that contains the error. Then, after you fix all the errors, you can save your work and run the validation scan again.

Although it’s estimated that 99% of all pages on the Web today haven’t been validated, we think it’s worth validating every page you develop. That’s because validating your pages can avoid testing problems later on. And, because Dreamweaver makes validating pages so easy, there’s no reason not to do it.
The Validation panel with three errors

How to run a validation scan for a web page

- Choose File → Validate → Validate Current Document (W3C). When a message is displayed alerting you that the web page will be sent to the W3C Markup Validation Service for validation, click OK.
- After the page is validated, a new group of panels will be displayed at the bottom of the Dreamweaver IDE and the Validation panel will be displayed. This panel lists any errors that were found.
- To move to the line of code that contains an error in the Document window, double-click on the error in the Validation panel.

Description

- You should validate your web page to be sure that the code it contains is compliant with the current HTML standards. Before you validate a web page, you should save it.
- After you fix the errors, you can rerun the validation directly from the Validation panel by selecting the Validate Current Document (W3C) command from the W3C Validation menu (▶) at the left side of the panel.
- The W3C (World Wide Web Consortium) is an international community in which member organizations, a full-time staff, and the public work together to develop Web standards.
How to set browser preferences

When you install Dreamweaver, it scans your system to determine what browsers you have installed, and it includes those browsers in the Preview in Browser menu. If you install a browser after you install Dreamweaver, though, you can add that browser to this menu using the Preview in Browser category of the Preferences dialog box.

Figure 3-17 describes how you do that. It also describes how you can remove a browser from the list of browsers. You’ll want to do that if you remove the browser from your system. You can also change the name of a browser or the location of its executable file, but you’re not likely to do that.

The Preferences dialog box also lets you specify the browsers you want to use as your primary and secondary browsers. Then, you can display a page in these browsers using a keyboard shortcut. When you set a primary browser, for example, you can preview a page by pressing the F12 key (Windows) or Option+F12 (Mac). And when you set a secondary browser, you can preview a page by pressing Ctrl+F12 (Windows) or Cmd+F12 (Mac). In this figure, you can see that Google Chrome is set as the primary browser.
The Preview in Browser category of the Preferences dialog box

Description

- To display the Preview in Browser category of the Preferences dialog box, choose Edit Browser List from the Preview in Browser menu in the Document toolbar.

- To add a browser to the list, click the Add Browser button (+) to display the Add Browser dialog box. Then, enter a name for the browser and click the Browse button to browse for and select the executable file for the browser.

- To remove a browser from the list, select the browser and then click the Remove button (-).

- To change the name of the browser or the location of its executable file, select the browser and then click the Edit button to display the Edit Browser dialog box.

- By default, the primary browser is set to your system’s default browser. To change that, select another browser and then select the Primary Browser option. To preview a page in that browser, press F12 (Windows) or Option+F12 (Mac).

- To set a browser as the secondary browser, select the browser and then select the Secondary Browser option. To preview a page in that browser, press Ctrl+F12 (Windows) or Command+F12 (Mac).

- You can also use the Add Browser and Edit Browser dialog boxes to set a browser as the primary or secondary browser.
How to delete, edit, and duplicate sites

As you learn Dreamweaver, you’ll probably create a variety of sites. Then, you’ll want to know how to manage the sites you create. Figure 3-18 presents the basic skills for doing that. Specifically, it describes how to use the Manage Sites dialog box to delete, edit, and duplicate sites.

In addition to these functions, you can use the Manage Sites dialog box to import and export Dreamweaver sites. You’ll learn how to do that in chapter 13. You can also add a new Dreamweaver site or import or add a Business Catalyst site. Business Catalyst is Adobe’s cloud-based hosting service that features content management-type functionality for your sites. For more information, see the Adobe website.
The Manage Sites dialog box

![Manage Sites dialog box](image)

**Description**

- The Manage Sites dialog box lists all of your current Dreamweaver sites. To display this dialog box, choose Site ➔ Manage Sites.

- To delete a site, select the site from the Your Sites list and then click the Delete icon (−). That deletes the Dreamweaver site, but not the files it contains.

- To edit a site, select the site from the Your Sites list and then click the Edit icon (修改). This displays the Site Setup dialog box you saw in figure 3-1. You can edit any of the site settings from this dialog box.

- To create a copy of a site, select the site from the Your Sites list and then click the Duplicate icon (复制). Another site with “copy” appended to the name will be added to the list. Then, you can select this site and click the Edit icon to change its settings.

- You can also use the Manage Sites dialog box to import and export sites. See chapter 13 for more information.

Figure 3-18 How to delete, edit, and duplicate sites
Perspective

This chapter has presented the critical skills for building websites in Dreamweaver without coding the HTML and CSS yourself. If you already know HTML and CSS, you can use these skills to build substantial web pages right now. In the next three chapters, though, you’ll learn the other skills that you’ll use for most of the websites that you build.

Terms

<table>
<thead>
<tr>
<th>Dreamweaver site</th>
<th>Element Live Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML Property Inspector</td>
<td>Code Navigator</td>
</tr>
<tr>
<td>Insert panel</td>
<td>validate a web page</td>
</tr>
<tr>
<td>style rule</td>
<td>Validation panel</td>
</tr>
<tr>
<td>style</td>
<td>World Wide Web Consortium (W3C)</td>
</tr>
<tr>
<td>CSS Designer</td>
<td>preview a web page</td>
</tr>
<tr>
<td>CSS Property Inspector</td>
<td>Live view</td>
</tr>
</tbody>
</table>

Summary

- When you create a Dreamweaver site, Dreamweaver establishes a reference between that site and the files for the website on your computer.
- After you create a site, you can add web pages to it, define the basic appearance of the pages using the Page Properties dialog box, and add content like text and images to the pages.
- The HTML Property Inspector generates HTML code based on the selections you make. You can also use the Insert panel to add HTML to a page.
- You can use the CSS Designer to create and modify style rules and styles. You can also modify some of the styles for a style rule by using the CSS Property Inspector.
- You can use Element Live Display to add an ID or class to an element or to remove an ID or class.
- You can use the CSS Designer to create external style sheets, move style rules from one style sheet to another, copy styles from one style rule to another, and attach an external style sheet to a web page.
- If you create an external style sheet for printing, you should change the text so it’s easy to read and remove unnecessary elements like images.
- When you validate a web page, Dreamweaver sends your web page to the W3C Markup Validation Service and then displays any errors in the Validation panel.
- You can use the Manage Sites dialog box to delete, edit, and duplicate any sites you’ve created.
Exercise 3-1   Build a web page

In this exercise, you’ll use the Dreamweaver skills that you learned in this chapter to build a web page that looks like the one below. This is an important exercise because it starts the process of mastering the Dreamweaver IDE. As you do the steps in this exercise, remember that you can undo any HTML or CSS change that doesn’t work right by using the Edit→Undo command or its shortcut keys.

Create a site and start a new page
1. Start Dreamweaver, and choose Site→New Site to create a new site named Exercise 3-1 for this folder:
   C:\dreamweaver\exercises\ex03-01\
2. In the Files panel, review the folders and files for this site. Note the normalize.css file in the styles folder and the four images in the images folder.

3. With figure 3-2 as a guide, use File→New to create a new html file, and use File→Save As to save the file as index.html in the ex03-01 folder.

Add the HTML5 structure for the page

4. In Design view, put the insertion point in the upper left corner, and use the Insert panel to insert a main element.

5. Delete the text that Dreamweaver put into the main element, leave the insertion point in the main element, and use the Insert panel to insert a header element.

6. Switch to Code or Split view to make sure that a header element is within the main element. Then, start a new line after the header element, leave the insertion point at the start of this line, and use the Insert panel to insert a section element.

7. Switch to Live view, click anywhere in the section, and use the Tag selector to select the section element. Then, use the Insert panel to insert a footer element, and click the After icon to insert it after the section element. Now, check the code to make sure this worked right.

At this point, the HTML code should have header, section, and footer elements within the main element, and the main element should be within the body element. This is a typical structure for an HTML5 document.

Add the HTML content

8. Switch to Design view, delete the Dreamweaver text in the section element, open the welcome.txt file in the ex03-01 folder, and copy and paste the text into the section element of the index.html file. Then, switch to Code view to see that the text paragraphs are within HTML <p> elements. Check also to make sure that the paragraphs are within the section element.

9. In Design view, use the HTML Property Inspector to change the “Welcome” paragraph to a Heading 1 paragraph, the “Our Solutions” paragraph to a Heading 2 paragraph, and the three product name paragraphs to Heading 3 paragraphs. Live view now shows the default formatting for these headings.

10. In Design view, delete the Dreamweaver text in the header, drag the logo.gif file from the images folder, and drop it into the header.

11. In Design view, drag and drop the product gif files in the images folder to the left of the related product names in the Heading 3 elements. If the elements are dropped within the Heading 3 elements, the images and headings will stay on the same line.

12. In Live view, double-click on the footer element. Then, replace the Dreamweaver text in the footer with this text:
   Copyright 2014 Module Media

13. In the Document toolbar in Design view, enter this title in the Title text box:
   Vecta Corp Home Page
14. Display the Standard toolbar by right-clicking on the right side of the Document toolbar and selecting Standard. Then, click the Save button to save the changes that you’ve made, and preview the page in your default browser. Note the title in the title bar or tab for the page, and note that the page has all of the required content. That content just needs to be formatted.

**Add the CSS that formats the text**

15. With figure 3-8 as a guide, use the CSS designer to create an external style sheet named styles.css in the styles folder. This automatically adds a link element to the HTML that attaches the style sheet to the page.

16. In Live view so you can see the changes, create a style rule and style for the body tag, as shown in figure 3-8. To do that, select the styles.css style sheet in the Sources pane, click the + icon in the Selectors pane, and enter “body”. Then, in the Properties pane, select the Text icon, set the font-family property to the option that starts with Gill Sans, and note the changes in Live view.

17. Use the CSS Designer to create a style rule for the h1 element that sets its color to red. To start, select the styles.css file in the Sources pane, and click on the Sources header so all of the styling that follows will apply to the styles.css style sheet. Then, click on the h1 element in Live view, click the + icon in the Selectors pane, and note that “main section h1” is the default selector. To change that to just “h1”, press the up-arrow key on the keyboard twice, and then press the Enter key. Last, select the Text category in the Properties pane, and set the color property to #CC1C0D.

18. Create a style rule for the h2 element that sets its color to the same red as the h1 element, and note the change in Live view.

19. Create a style rule for the footer that sets the text-align property to “right”. This should align the footer text on the right of the page. Then, check the Show Set box to display just the properties that have been set for the footer.

20. Create a style rule for the header that sets its text-align property to “center”. This should center the image in the header.

21. Test the page in your default browser so see how it’s coming along.

**Add the CSS that provides background colors and centers the page**

22. Create a style rule for the main element. Then, set its width property to 700 pixels, and test that change in your default browser. That property and the ones that follow are in the Layout category.

23. Set the left and right margins for the main selector to “auto” and test that change in your default browser. The page should now be centered in the window.

24. Set the padding for all four sides of the main selector to 25 pixels. One way to do that is to click “Set Shorthand” for the padding property, and then enter 25px to set the padding for all four sides. The other way to do that is to click in the center of the padding box, and then set the padding for one of the sides. That should set the padding for all of the sides.
25. Set the background-color property of the main selector to white (#FFFFFF). This property is the first one in the Background category. Then, set the background color of the body selector to #DFE3E6, and test these changes in your default browser. The page should now be centered with a white background that’s surrounded by a darker background, but that may not be true for all browsers or for Live view.

**Finish the page**

26. Attach the normalize.css style sheet that’s in the styles folder, but make sure it’s before the styles.css style sheet. An easy way to do that is to switch to Code view, start a new line before the link element for the styles.css sheet, and drag the normalize.css file from the Files panel to the start of the new line. Now, test the page again to see that this fixed any browser differences.

27. With figure 3-16 as a guide, validate the web page to see if it has any errors. If it does, be sure to fix them.

28. Test the page one last time to make sure everything looks the same as the page shown at the start of this exercise. Then, review the HTML and CSS code that you’ve created.

29. If you want to make other modifications to the page, by all means experiment. When you’re through, close all of the files.

---

**Exercise 3-2 Create an Exercises site and delete the old sites**

In this exercise, you’ll create one site that you can use for all of the exercises so you won’t have to create a separate site for each one. You’ll also delete the sites that you’ve already created because you won’t need them anymore.

**Create a site for all of the exercises**

1. Choose Site ➔ New Site to create a new site named Exercises that starts with this folder:
   
   C:\dreamweaver\exercises\

2. Open the ex03-01 folder to see that it contains the folders and files for the exercise that you just finished.

**Delete the sites you no longer need**

3. With figure 3-18 as a guide, delete the sites that you created for specific exercises, like the Exercise 1-1, Exercise 2-1, and Exercise 3-1 sites.

**Create a site for all of the solutions**

4. At this point, you should have a Book applications site for accessing all the book applications and an Exercises site for accessing all of the exercises. Now, if you want to create a third site named Solutions for accessing all of the exercise solutions, they should be in this folder:
   
   C:\murach\dreamweaver\solutions\
How to build your Dreamweaver skills

The easiest way is to let Murach’s Dreamweaver CC 2014 be your guide! So if you’ve enjoyed this chapter, I hope you’ll get your own copy of the book today. You can use it to:

- Teach yourself how to create web pages the way so many professionals do, using Dreamweaver to work as efficiently as possible
- Learn what you need to know about HTML and CSS (including HTML5 and CSS3) so you can work with the code that Dreamweaver generates
- Create sites that look great and work right on any computer or mobile device by using Responsive Web Design
- Enhance your web pages with JavaScript and jQuery features like image swaps, photo galleries, and accordions...all without knowing JavaScript and jQuery!
- Pick up new skills whenever you want to or need to by focusing on material that’s new to you
- Look up the operational details that are hard to remember when you’re in the middle of developing a website
- Loan to your colleagues who are always asking you questions about Dreamweaver

To get your copy, you can order online at www.murach.com or call us at 1-800-221-5528 (toll-free in the U.S. and Canada). And remember, when you order directly from us, this book comes with my personal guarantee:

100% Guarantee

You must be satisfied. Each book you buy directly from us must outperform any competing book or course you’ve ever tried, or send it back within 60 days for a full refund...no questions asked.

Thanks for your interest in Murach books!