Thanks for downloading this chapter from *Murach’s Oracle SQL and PL/SQL for developers (2nd Edition)*. We hope it will show you how easy it is to learn from any Murach book, with its paired-pages presentation, its “how-to” headings, its practical coding examples, and its clear, concise style.

To view the full table of contents for this book, you can go to our [web site](http://www.murach.com). From there, you can read more about this book, you can find out about any additional downloads that are available, and you can review our other books on related topics.

Thanks for your interest in our books!
What developers have said about the previous edition

“I bought this book to take my SQL skills up a notch or more. This book really does that. It moves from the basics to advanced queries. The advanced queries are very well explained and you get useful skills and understand how to extend this to other queries.”

Posted at an online bookseller

“Inner and outer joins have never made as much sense as they did after completing Murach’s Oracle SQL. Additionally, working with user-defined PL/SQL functions and triggers was new ground for a self-taught coder like myself.”

Todd Jensen, GravitateOnline.com

“This book explained many of the ‘Oracle’ ways to do the stuff I already do with SQL Server. It is open daily when I work on Oracle code now.”

Posted at an online bookseller

“This book is worth its cost just for its detailed and complete description of the SQL SELECT statement. The book takes 4 chapters (129 pages) to cover all aspects of it. I have not found any other book, including Oracle’s own documentation, which more completely describes how to use the SELECT statement.”

Eric Mortensen, North East Ohio Oracle Users Group

“A lifesaver! Got stuck on one of my Oracle assignments and it took just one look in this book and I was all set and ready to take on other assignments. It is really a reliable reference book.”

Posted at an online bookseller

“A book that is great for Oracle novices, but also great for casual intermediate users like myself.”

David O’Meara, JavaRanch.com
In the last chapter, you learned about some of the SQL statements that you can use to work with the data in a relational database. Before you learn the details of coding these statements, however, you need to learn how to work with an Oracle database and how to use Oracle SQL Developer to enter and execute SQL statements. It’s also helpful to know how to use the SQL Reference manual.
How to work with an Oracle database

Since Oracle Database 12c Express Edition has not been released as of press time for this book, this topic uses Oracle Database 11g Express Edition to illustrate the skills for working with the Oracle Database. However, when the Express Edition of 12c becomes available, you should be able to use similar techniques to work with that version of the Oracle Database.

How to start and stop the database service

If you installed the Express Edition of the Oracle Database on your computer as described in appendix A, the database service starts automatically when you start your computer. This piece of software is often referred to as the database server, or the database engine. It receives SQL statements that are passed to it, processes them, and returns the results.

The database listener also starts automatically when you start your computer. This piece of software listens for requests from remote clients and returns the results to them.

From time to time, you may want to stop the database. If, for example, you aren’t going to be using the database and you want to free the resources on your computer, you can stop the database. Or, if the port that is being used by the Oracle Database conflicts with another program, you can stop the database. Then, when you want to work with the database again, you can start it.

The easiest way to stop the database service is to use the Stop Database command that’s available from the Windows Start menu as described in figure 2-1. When you select this item on a Windows system, a DOS window will be displayed that indicates that the Oracle service is stopping. Then, the DOS window will display a message when the Oracle service has successfully stopped. Although this doesn’t stop the database listener, the database listener won’t be able to return any results unless the database service is running.

When you’re running the Oracle Database on your own computer for training purposes, you can stop the database whenever you want. However, if a database is running in a production environment, you should make sure that all users are logged off and that no applications are using the database before you stop the database.

The easiest way to start the database service and listener is to use the Start Database command that’s available from the Windows Start menu. When you select this command on a Windows system, a DOS window will be displayed that indicates the status of the Oracle listener and service.
How to stop the database

- Start ➔ All Programs ➔ Oracle Database 11g Express Edition ➔ Stop Database

The DOS window that’s displayed when the database is being stopped

How to start the database

- Start ➔ All Programs ➔ Oracle Database 11g Express Edition ➔ Start Database

The DOS window that’s displayed when the database is started

Description

- After you install the Oracle Database, the *database service* and *database listener* starts automatically each time you start your computer. The database service can also be referred to as the *database server* or the *database engine*.
- To stop or start the database server and listener, you can use the commands that are available from the Windows Start menu.
- When Oracle Database 12c Express Edition becomes available, you should be able to use a similar technique to stop and start that version of the Oracle Database.
How to use the Database Home Page

Figure 2-2 shows how to use a web-based tool known as the Database Home Page to work with an Oracle database. This tool is installed when you install the Oracle Database as described in appendix A, and it’s useful for handling some tasks. In particular, it provides a way to create a new user for the database.

To begin, you can start the Database Home Page by selecting the Oracle Database 11g Express Edition ➔ Get Started command from the Windows Start menu. Then, select the Application Express tab, and log in as the system user. If you followed the advice of appendix A, that means you’ll use “system” as the username and “system” as the password.

After you’ve logged in, you can use the resulting web page to create a new user. When you create a new user, you provide a username and a password. In addition, you must provide a username for Application Express. In this book, you don’t need to use that username for anything.

You can get a feel for the information that’s available from the Database Home Page by clicking on its tabs. However, this tool doesn’t provide much functionality. To perform most tasks, you can use the SQL Developer tool that’s described later in this chapter.
The Database Home Page

How to start the Database Home Page
- From the Windows Start menu, select All Programs→Oracle Database 11g Express Edition→Get Started.

How to create a user
- From the Database Home Page, click the Application Express tab. If necessary, log in as the system user. Then, use the resulting page to create the user.

Description
- The Database Home Page is a web-based tool that you can use to work with an Oracle Database.
- After you log in, you can use the Home, Storage Sessions, Parameters, and Application Express menus to work with the database.
- For most tasks, it’s easier to use the SQL Developer tool that’s described later in this chapter.

Figure 2-2   How to use the Database Home Page
How to use SQL*Plus

Figure 2-3 shows how to use a command-line tool known as SQL*Plus to work with the database. SQL*Plus has been around since the earliest days of the Oracle database, and many Oracle developers still use it. However, the newer SQL Developer tool described later in this chapter is easier to learn and use than SQL*Plus. That’s why this chapter and the rest of this book shows how to work with SQL Developer.

Still, there may be times when it makes sense to use SQL*Plus. If, for example, you are working on a computer that has SQL*Plus installed but doesn’t have SQL Developer installed, you may need to use SQL*Plus to run some SQL statements. Or, you may need to develop a batch file that uses SQL*Plus to run one or more SQL scripts. Figure A-5 of appendix A shows how to run a batch file that starts SQL*Plus and uses it to run four SQL scripts. In that case, of course, it makes sense to use SQL*Plus.

If you need to start SQL*Plus, you can do that by running the sqlplus.exe file. One easy way to do that is to enter “sqlplus” on the Windows Start menu and select the sqlplus.exe file when it appears. Then, you can connect to the database as a user by entering the username and password. In this figure, for example, I started by connecting as the AP user.

Once you’re connected to the database, you can run SQL statements. To do that, you type the SQL statement followed by a semicolon and press the Enter key. Then, if the statement selects data, SQL*Plus will display the data. In this figure, for example, I entered a SQL statement that displays the vendor_name for the vendor with an id of 11.

At any time, you can connect to the database as a different user by entering the CONNECT command. When you enter this command, SQL*Plus prompts you for a username and password. In this figure, for example, I entered the CONNECT command to connect as the OM user.
SQL*Plus

Description

- SQL*Plus is a command-line tool that you can use to work with an Oracle Database.
- To start SQL*Plus, find the sqlplus.exe file and run it. One easy way to do that is to use the Windows Start menu to search for “sqlplus”. Then, you can select the sqlplus.exe file when it appears on the Start menu.
- To connect to a database, enter the username and password. If necessary, you can enter the CONNECT command to have SQL*Plus prompt you for a username and password.
- To run a SQL statement, type it, type a semicolon, and press the Enter key.
- For most tasks, it’s easier to use the SQL Developer tool that’s described later in this chapter.
How to use SQL Developer to work with a database

Oracle SQL Developer is a free graphical tool that makes it easy to work with Oracle databases, and it’s the tool that we recommend for working with an Oracle database. As you will see, this tool makes it easy for you to review or modify the design of a database.

As of press time for this book, the current version of SQL Developer is version 4.0, so that’s the version presented in this chapter. However, with some minor variations, the skills presented in this chapter should work for later versions as well.

When you use SQL Developer, you can connect to any Oracle Database version 9.2.0.1 or later. To connect to earlier versions, you need to use another tool such as the SQL*Plus tool described in the previous figure.

How to create a database connection

Before you can work with a database, you need to create a connection to the database. When you start SQL Developer, the Connections window displays all available database connections. To create a new connection, you can use the procedure described in figure 2-4.

If you have installed the software for this book as described in figure A-5 of appendix A, the AP, OM, and EX users with passwords of AP, OM, and EX will be available on your system. As a result, you will be able to create connections for these three users. Specifically, we suggest that you use the AP user to work with the tables in the AP schema, the OM user to work with the tables in the OM schema, and the EX user to work with the tables in the EX schema.

When you create a database connection, you should note that the usernames and passwords are not case-sensitive. As a result, it doesn’t matter if you enter the usernames and passwords in uppercase or lowercase. In this figure, for example, I entered the usernames and passwords in lowercase because it’s easier to type in lowercase.

How to export or import database connections

If you want to copy several database connections from one computer to another, you can export the database connections to an XML file as described in this figure. Then, you can use this XML file to import those database connections on another computer. For example, I exported the database connections for the AP, OM, and EX users to this file:

```
c:\murach\oracle_sql\db_setup\connections.xml
```

As a result, if you want, you can use the technique shown in this figure to import the connections that are stored in this file.
The dialog box for creating database connections

How to create a database connection

1. Right-click on the Connections node in the Connections window and select the New Connection command to display the dialog box for creating database connections.
2. Enter a connection name, username, and password for the connection.
3. Click the Test button to test the connection. If the connection works, a success message is displayed above the Help button.
4. Click the Save button to save the connection. When you do, the connection will be added to the dialog box and to the Connections window.

How to export or import database connections

- To export database connections, right-click the Connections node, select the Export Connections command, and use the resulting dialog box to select the connections that you want to export and to specify the path and filename for the XML file for the connections.
- To import connections, right-click the Connections node, select the Import Connections command, and use the resulting dialog box to navigate to the XML file for the connections. Then, select the connections that you want to import.
Section 1  An introduction to SQL

How to navigate through the database objects

Figure 2-5 shows how to navigate through the database objects that are available to the user that corresponds with the current database connection. These database objects include tables, views, indexes, and so on. For this chapter, however, you can focus on the tables. Later in this book, you’ll learn more about views, indexes, and other database objects.

When you expand a connection for the first time in a session, you must enter the password for the username in the Connection Information dialog box. In this figure, for example, I clicked on the plus sign (+) to the left of the node for the AP connection. Then, SQL Developer prompted me for the password for the user named AP. When I entered the correct password, SQL Developer expanded the AP connection and displayed a SQL Worksheet window for the AP connection.

Once you expand a connection, you can navigate through the objects that are available for the user that corresponds to the connection. To do that, you can click on the plus (+) and minus (-) signs to the left of each node to expand or collapse the node. In this figure, for example, I expanded the Tables node to view all of the tables available to the AP user.

To work with a node or an object, you can right-click on the object to display a context-sensitive menu. Then, you can select a command from the resulting menu. For example, you can right-click on the node for the AP connection to display a list of commands for working with that connection.
The Connection Information dialog box

![Connection Information dialog box](image)

The tables available to the AP user

![Oracle SQL Developer](image)

Description

- Each connection provides access to the database objects that are available to the user that corresponds with the connection. These database objects include tables, views, and so on.

- Before you can expand a connection for the first time in a session, you must enter the correct password for the connection. Once you enter a password for a connection, you can navigate through the nodes for the database objects. You can also use the SQL Worksheet window to enter and run SQL statements.

- To navigate through the database objects for a connection, click on the plus (+) and minus (-) signs to the left of each node to expand or collapse the node.

- To work with a node or an object, right-click on the node or object and select a command from the resulting menu.

Figure 2-5 How to navigate through the database objects
How to view the column definitions for a table

To view the column names for a table, you can expand the node for the table. In figure 2-6, for example, I expanded the node for the Vendors table so the names for all of columns in the table are displayed below the table.

To view the column definitions for a table, you can click on the table name to display a table that contains the definition of each column. In this figure, for example, the right-hand window shows a table that contains the definitions for each column in the Vendors table. For each column, this table shows the column name, the data type, an indication of whether or not the column can contain null values, the default value, the position of the column within the table, whether or not the column is a primary key, and any column comments. By default, the columns are displayed in the sequence in which they were created.

How to view the data for a table

To view the data for a table, you just click on the Data tab after you display the column definitions for the table. By switching back and forth between the Column and Data tabs, you can quickly see how the data corresponds to the data definitions.

You can also use the Data tab to modify the data in a row, and you can use the Insert and Delete buttons at the start of this tab to add rows or delete rows. Then, if you want to commit the changes to the table, you can click on the Commit Changes button. Or, if you want to rollback the changes, you can click on the Rollback Changes button. In chapter 7, you’ll learn more about committing and rolling back changes.
How to view the column definitions for a table

- To view the column names for a table, expand the Tables node and then expand the node for the table you wish to view. This displays the columns in the Connections window.

- To view the column definitions for a table, click on the name of the table in the Connections window. This displays detailed information about the columns of the table in the window to the right of the Connections window.

- By default, the columns are displayed in the sequence in which they were created.

How to view the data for a table

- Click on the Data tab in the window that’s displaying the column definitions for the table.
How to edit the column definitions

If you want to edit a column definition, you can use one of the techniques described in figure 2-7 to display the Edit Table dialog box. Then, you can use this dialog box to add a column, delete a column, or modify a column.

If you want to display additional information about a column, you can select the column by clicking on it. Then, additional properties are displayed in the Column Properties group that’s displayed on the right side of the dialog box. In this figure, for example, the properties for the DefaultTermsID column are displayed. In addition, a default value of 3 has been entered for this column. Note that the properties that are available change depending on the data type of the column. For a column with the VARCHAR2 data type, for example, the properties also indicate the length of the column. You’ll learn more about that in chapter 8.

Most of the time, you won’t want to use SQL Developer to edit the column definitions for a table. Instead, you’ll want to edit the scripts that create the database so you can easily recreate the database later. However, if necessary, you can use SQL Developer to edit the column definitions for a table. In chapter 10, you’ll learn more about creating and modifying the column definitions for a table.
How to edit the column definitions of a table

Description

- To edit the definition of a table, right-click on the table name, select the Edit command, and use the Edit Table dialog box to modify the table.
- You can use the Edit Table dialog box to add a column, delete a column, or change the properties of an existing column such as the name, data type, default value, and so on.
- You can also use the Edit Table dialog box to add, delete, or modify a table-level constraint, an index, or a table-level comment.
- For more information about creating tables, see chapter 10.

Figure 2-7  How to edit the column definitions
How to use SQL Developer to run SQL statements

Besides letting you review the design of a database, SQL Developer is a great tool for entering and running SQL statements. That’s what you’ll learn how to do next.

How to enter and execute a SQL statement

Figure 2-8 shows how to use the SQL Worksheet window to enter and execute a SQL statement. The easiest way to open a SQL Worksheet window is to use the drop-down list that’s available from the Open SQL Worksheet button on the toolbar. First, you can click on the arrow to the right of this button to display all connections. Then, you can select the connection you want to use. This opens a Worksheet for that connection. But first, if the connection hasn’t been used in the current session, you may be prompted to enter the password for the connection.

Once you open a SQL Worksheet, you can use standard techniques to enter or edit a SQL statement. As you enter statements, you’ll notice that SQL Developer automatically applies colors to various elements. For example, keywords are displayed in blue. This makes your statements easier to read and understand and can help you identify coding errors.

When you enter SQL statements, you’ll notice that SQL Developer automatically displays a drop-down list that helps you enter SQL statements. This feature often provides help for entering SQL keywords, table names, column names, and so on. In this figure, for example, SQL Developer displayed a drop-down list after I entered the ORDER BY keywords and pressed the spacebar. At this point, you can easily select a column name from the drop-down list.

If you experiment with this code completion feature, you’ll find that SQL Developer doesn’t display column names automatically until you enter the name of the table that’s used by the statement. As a result, if you want to use the code completion feature, you may want to enter the table name before you enter the column names.

Most of the time, SQL Developer automatically displays the drop-down list after you enter some code followed by a space. Usually, that’s what you want. However, there are times when you may want to manually prompt SQL Developer to display the drop-down list. To do that, you can press the Ctrl key and the slash at the same time (Ctrl+/).

In addition, you can use SQL Developer to automatically comment or uncomment a line. To do that, you can move the insertion point into the line. Then, you can press the Ctrl key and the front slash at the same time (Ctrl+/).

To execute a single SQL statement like the one in this figure, you can press F9 or click the Execute Statement button in the toolbar for the SQL Worksheet window. If the statement returns data, that data is displayed in the Results tab. In this figure, for example, the result set returned by the SELECT statement is displayed. If necessary, you can adjust the height of the Results pane by dragging the bar that separates the SQL Worksheet window from the Results tab.
A SELECT statement and its results

Description

- To open a new SQL Worksheet window, drop down the list from the Open SQL Worksheet button. Then, select the connection you want to use.
- To change the connection for the worksheet, use the Connections list.
- To enter a SQL statement, type it into the SQL Worksheet window.
- As you enter the text for a statement, the SQL Worksheet window applies color to various elements, such as SQL keywords, to make them easy to identify.
- As you enter the text for a statement, you can use the code completion feature to select SQL keywords, table names, column names, and so on.
- To manually display the code completion list, press Ctrl+spacebar.
- To comment out a line or to uncomment a line, press Ctrl+/.
- To execute a SQL statement, press the F9 key or click the Execute Statement button (▶) in the toolbar. If the statement retrieves data, the data is displayed in the Results tab of the SQL Worksheet window.

Figure 2-8   How to enter and execute a SQL statement
How to work with the Snippets window

Figure 2-9 shows how to use the Snippets window to enter a snippet of code into the SQL Worksheet window. To start, if the Snippets tab isn’t displayed on the right side of the SQL Developer window, you can select the Snippets command from the View menu to display the Snippets window. Otherwise, you can display the Snippets window by clicking on the Snippets tab that’s displayed on the right side of the SQL Developer window. Then, you can use the drop-down list at the top of the Snippets window to select a category of snippets, and you can drag a snippet from the Snippets window into the SQL Worksheet window. At that point, you can edit the snippet code so it’s appropriate for your SQL statement.

In this figure, for example, I dragged the COUNT(*) and SUM(expr) snippets into the SQL Worksheet window. Then, I edited the SUM(expr) snippet to replace the expr placeholder with a valid expression.

For now, don’t worry if you don’t understand the SQL statement presented in this figure. The main point is that you can use the Snippets window to enter a variety of SQL code. As you learn more about SQL statements, you’ll see how useful this can be.
How to use the Snippets window

Description

- If the Snippets tab isn’t displayed on the right side of the SQL Developer window, you can display it by selecting the Snippets command from the View menu.
- To display the Snippets window, click on the Snippets tab that’s displayed on the right side of the SQL Developer window.
- To display another category of snippets, select the category from the drop-down list at the top of the Snippets window. The snippets are organized in categories including: Date Formats, Number Formats, Date/Time Functions, Number Functions, Character Functions, Conversion Functions, and Pseudocolumns.
- To enter a snippet into your code, drag the snippet from the Snippets window into the SQL Worksheet window. Then, if necessary, edit the snippet code so it’s appropriate for your SQL statement.
- The Snippets window will become more useful as you learn more about formats and functions.
How to handle syntax errors

If an error occurs during the execution of a SQL statement, SQL Developer displays the error in the Query Result window. This includes the error number, a brief description of the error, and the location of the error in your code. In figure 2-10, for example, the Query Result window displays an error number of “ORA-00942” and a brief description that says “table or view does not exist.” This dialog box also indicates that the error occurred at line 2, column 6, where a table or view named Vendor is referenced.

In this example, the problem is that the Vendor table doesn’t exist in the database. To fix the problem, you need to edit the SQL statement so the table is Vendors instead of Vendor. Then, you should be able to successfully run the SQL statement.

This figure also lists some other common causes of errors. As you can see, most errors are caused by incorrect syntax. However, it’s also possible that you will get an error if you are connected as the wrong user. If, for example, you are connected as the EX user and you try to run a statement that references tables in the AP schema, you may get an error. Regardless of what’s causing the problem, you can usually identify and correct the problem without much trouble. In some cases, though, it may be difficult to figure out the cause of an error. Then, you can usually get more information about the error by searching the Internet.
How to handle syntax errors

Common causes of errors

- Misspelling the name of a table or column
- Misspelling a keyword
- Omitting the closing quotation mark for a character string
- Being connected as the wrong user

Description

- If an error occurs during the execution of a SQL statement, SQL Developer displays the error in the Query Result window. This includes the error code, a brief description of the error, and the location of the error in the code.
- Most errors are caused by incorrect syntax and can be corrected without any additional assistance. Otherwise, you can usually get more information about an error by searching for the error code or description on the Internet.
How to open and save SQL statements

After you get a SQL statement working the way you want it to work, you may want to save it. Then, you can open it and run it again later or use it as the basis for a new SQL statement. To save a SQL statement, you can use the standard Windows techniques shown in figure 2-11.

To open a file that has been saved, you use the Open command. In this figure, for example, the Open dialog box shows the SQL statements that have been saved for chapter 3. They are saved in the scripts\ch03 directory that is created when you download and install the source code for this book. The screen in this figure shows the tabs for three files that have been opened for that chapter. Note that the names of these files have the sql extension.

After you open two or more SQL worksheets, you can switch between the SQL statements by clicking on the appropriate tab. Or, you can select the SQL statement from the file list that’s available just above the Connections list. Then, you can cut, copy, and paste code from one SQL statement to another.

When you open a saved SQL file, SQL Developer doesn’t set a connection for the SQL statement within the file. As a result, you must specify a connection before you can run the SQL statement by using the Connections list. If you don’t do that, SQL Developer will prompt you to select a connection when you try to run the statement.

To save a new SQL statement in a new file, you use the Save command. To save a modified SQL statement in its original file, you also use the Save command. And to save a modified SQL statement in a new file, you use the Save As command.

To set the default directory that you want to use for saving new SQL statements, you can use the Tools→Preferences command that’s described in this figure. Note, however, that there’s no way to set the default directory for opening files.

For both the Open and Save dialog boxes, you can specify a recently used directory by clicking on its icon. In this figure, for example, the Open dialog box shows that the db_setup directory has been used recently. As a result, you can easily specify one of these directories by clicking on it.
The Open File dialog box

Description

- To open a SQL file, click the Open button in the toolbar, press Ctrl+O, or select the File→Open command. Then, use the Open dialog box to locate and open the SQL file.
- To specify a connection for a SQL statement that you open, select a connection from the Connections list (see figure 2-8). Otherwise, when you try to run the statement, SQL Developer will display a dialog box that prompts you to select a connection.
- To switch between open statements, select the appropriate tab. Or, click on the drop-down arrow that’s displayed to the right of the SQL Worksheet tabs, and select the file name from the file list.
- To cut, copy, and paste code from one SQL statement to another, use the standard Windows techniques.
- To save a SQL statement, click the Save button in the toolbar, press Ctrl+S, or select the File→Save command. Then, if necessary, use the Save dialog box to specify a file name for the SQL statement.
- To change the default directory for new statements that you want to save, use the Tools→Preferences command. Then, expand the Database node, click on the Worksheet node, and change the default path for scripts.
- To specify a recently used directory in an Open or Save dialog box, click on the icon for the recently used directory.

Figure 2-11  How to open and save SQL statements
How to enter and execute a SQL script

A SQL script is a file that contains one or more SQL statements. So far in this chapter, each of the SQL files that has been presented has been a SQL script that contains just one SQL statement. However, a SQL script typically contains multiple statements.

When you code multiple SQL statements within a script, you must code a semicolon at the end of each SQL statement. For example, figure 2-12 shows a script that contains two SQL statements. Then, you can press F5 or click the Run Script button to execute all of the SQL statements that are stored in the script. When you do, the results of the script will be displayed in the Script Output tab.

However, if you want to execute a single SQL statement that’s stored within a script, you can do that by moving the insertion point into the statement and pressing the F9 key or clicking the Execute Statement button in the toolbar. Then, if the statement retrieves data, the data is displayed in a Results tab like the one in figure 2-8. In this figure, for example, the insertion point is in the first SQL statement, and this statement is a SELECT statement that retrieves data. As a result, if you press the F9 key, the result set is displayed in the Results tab.
A SQL script and its results

Description

- A **SQL script** is a file that contains one or more SQL statements. When you code a script that contains more than one statement, you must code a semicolon at the end of each statement.
- To run the entire SQL script, press the F5 key or click the Run Script button (Run Script button) that’s located just to the right of the Execute Statement button. The results are displayed in the Script Output tab.
- To execute one SQL statement within a script, move the insertion point into the statement. Then, press the F9 key or click the Execute Statement button in the toolbar. If the statement retrieves data, the data is displayed in the Results tab.

Figure 2-12  How to enter and execute a SQL script
How to use the SQL Reference manual

Figure 2-13 shows how to use another useful tool for working with the Oracle Database: the SQL Reference manual. This manual is available as a searchable PDF file that contains detailed technical information about the SQL statements that work with Oracle Database. You can use this PDF file to quickly look up a wide variety of information about the Oracle Database including information about its SQL statements and functions.

How to view the manual

If you have the PDF file for the SQL Reference manual installed on your computer as described in appendix A, you can open the manual by using the Windows Explorer to double-click on the PDF file. This will open the PDF file in the Adobe Reader. Of course, this assumes that you have the Adobe Reader installed on your system. If you don’t, you can download it for free from Adobe’s web site.

How to look up information

Once you’ve opened the PDF file for the SQL Reference manual in the Adobe Reader, there are several ways that you can look up information. In short, you can use any standard techniques for working with a PDF file to work with this manual. If you need help, you can use the Adobe Reader’s Help menu to learn more about using Adobe Reader.

One easy way to look up information is to scroll through the table of contents. To do that, click on the plus (+) and minus (-) signs in the left column to expand or collapse the topics. Then, when you find the topic you want, click on it to display the topic in the right pane. Once you do that, you can scroll up or down to view the entire topic. In this figure, for example, I expanded the topic named “SQL Statements: SAVEPOINT to UPDATE,” and I clicked on the SELECT topic to display information about the SQL SELECT statement.

Another easy way to look up information is to search for a specific word or phrase. To do that, type the word or phrase in the Find text box and press the Enter key. Then, you can click on the Find Next or Find Previous button to find the next or previous occurrence of the word or phrase. In this figure, for example, I entered “select statement” into the Find text box and pressed the Enter key.
How to use the Oracle Database SQL Reference manual

Description
- The Oracle Database SQL Reference manual is available as a searchable PDF file that contains detailed technical information about the SQL statements that work with the Oracle Database.
- If you have the PDF file for the SQL Reference manual installed on your computer, you can start it by using the Windows Explorer to double-click on the file.
- To scroll through the table of contents, click on the plus (+) and minus (-) signs to expand or collapse the topics. When you find the topic you want, click on it to display the topic in the right pane. Then, you can scroll up or down to view the entire topic.
- To search for a particular word or phrase, type the word or phrase in the Find text box in the toolbar and press the Enter key. Then, you can click on the Find Next or Find Previous button to find the next or previous occurrence of the word or phrase.

Note
- The name of the Oracle Database SQL Reference manual varies slightly from one release to another.
Perspective

In this chapter, you learned how to use the tools that you need to work with an Oracle database and to enter and execute SQL statements. With that as background, you’re ready to go on to the next chapter, where you’ll start learning the details of coding your own SQL statements. To start, you’ll learn the details for coding a SELECT statement that retrieves data from a single table.

Before you go on to the next chapter, though, we recommend that you install all of the software for this book on your computer as described in Appendix A. You should also do the exercises that follow. That will get you off to a good start with Oracle Database and the Oracle Database tools.

Terms

<table>
<thead>
<tr>
<th>Oracle Database</th>
<th>database object</th>
</tr>
</thead>
<tbody>
<tr>
<td>database service</td>
<td>Oracle SQL Developer</td>
</tr>
<tr>
<td>database server</td>
<td>snippet</td>
</tr>
<tr>
<td>database engine</td>
<td>SQL script</td>
</tr>
<tr>
<td>database listener</td>
<td>Oracle Database SQL Reference</td>
</tr>
<tr>
<td>Database Home Page</td>
<td>manual</td>
</tr>
</tbody>
</table>
| SQL*Plus

Before you start the exercises...

Before you start the exercises for this chapter, you need to install Oracle Database Express Edition and Oracle SQL Developer. You also need to download and install the source files for this book, and you need to create the users and tables for this book. The procedures for doing all of these tasks are provided in appendix A.

Exercises

In these exercises, you’ll use SQL Developer to review the tables in the AP schema that’s used throughout this book. In addition, you’ll use SQL developer to enter SQL statements and run them against these tables.

Make sure Oracle Database is running

1. Use the procedure in figure 2-1 to start the database service for Oracle Database. If it is already running, you’ll get a message that confirms that. Otherwise, the database service will be started. Either way, you can close the DOS window that’s opened.

Use SQL Developer to review the Accounts Payable database

2. Start Oracle SQL Developer. If you created a menu or desktop shortcut when you installed SQL Developer, you can use that shortcut now. Otherwise, you can use the Windows Explorer to find and double-click on the sqldeveloper.exe file.
3. Create the AP, EX, and OM connections as described in figure 2-4. When you’re done, the Connections window should display three connections: AP, EX, and OM.

4. In the Connections window, click on the AP connection to expand it. When you’re prompted for a password, enter “ap”.

5. Use the techniques in figures 2-5 and 2-6 to navigate through the database objects and view the column definitions for at least the Vendors and Invoices tables.

6. Use the technique in figure 2-6 to view the data for the Vendors and Invoices tables.

**Use SQL Developer to enter and run SQL statements**

7. Use the technique in figure 2-8 to open a SQL Worksheet window for the AP connection. Then, enter and run this SQL statement:

```
SELECT vendor_name FROM vendors
```

8. Use the code completion feature described in figure 2-8 to enhance this SQL statement so it includes an ORDER BY clause and some additional columns like this:

```
SELECT vendor_name, vendor_address1, vendor_city, vendor_state, vendor_zip_code
FROM vendors
ORDER BY vendor_name
```

Then, run the statement.

9. Move the cursor into the ORDER BY clause and press Ctrl+/	 to comment out the line. Then, press Ctrl+/	 again to uncomment the line.

10. Delete the e at the end of vendor_zip_code and run the statement again. Note that this syntax error is handled as in figure 2-10.

11. Open another Worksheet window, and use the COUNT and SUM snippets as shown in figure 2-9 as you enter this statement:

```
SELECT COUNT(*) AS number_of_invoices,
     SUM(invoice_total) AS grand_invoice_total
FROM invoices
```

Then, run the statement.

12. Use the Tools→Preferences command to set the default path for scripts as described in figure 2-11. Then, click on the tab for the Worksheet window of exercise 8, click the Save button to save this statement, and note the directory in the Save dialog box. Next, click the Cancel button in the Save dialog box to cancel the command.

**Use SQL Developer to open and run scripts**

13. Use the technique in figure 2-11 to open the select_vendor_city_state script that’s in the c:\murach\oracle_sql\scripts\ch02 directory. Notice that this script contains just one SQL statement. Then, run the statement. Because you didn’t specify a connection for this statement, SQL Developer will ask you to select one before it runs the statement.
14. Click on the Open button. Note that the recently used directories including the ch02 directory are shown on the left side of the Open dialog box. Then, click on the ch02 directory to display the files that are stored in this directory. Next, click the Cancel button to close this dialog box.

15. Open the select_vendor_total_due script that’s in the ch02 directory. Note that this opens another tab. Next, select the AP connection from the connection list and run this script.

16. Open the select_vendor_information script that’s in the ch02 directory. Notice that this script contains two SQL statements that end with semicolons (scroll down if you need to). Then, move the insertion point to the first statement and press F9 to run that statement. Next, move the insertion point to the second statement and press F9 to run that statement. Last, press F5 or click the Run Script button to run both of the statements that are stored in this script. If you scroll through the Script Output window, you will see the results of the two SELECT statements that were run.

**Close and restart SQL Developer**

17. Continue to experiment on your own. Make sure to leave at least one saved script open. When you’re ready to end this session, use the File → Exit command or click on the Close button in the upper right corner of the SQL Developer window.

18. Restart SQL Developer. When it starts, notice that all of the saved scripts that you left open are automatically opened. However, any unsaved scripts that you entered are lost.

19. Run one of the open scripts. Note that you have to select a connection and provide a password for the connection before the script will run.

20. Exit from SQL Developer.
How to build your Oracle SQL skills

The easiest way is to let Murach’s Oracle SQL and PL/SQL for Developers (2nd Edition) be your guide! So if you’ve enjoyed this chapter, I hope you’ll get your own copy of the book today. You can use it to:

- Teach yourself how to code SQL statements to retrieve and maintain the data in an Oracle database
- Design and create your own Oracle databases using SQL DDL statements
- Use Oracle’s procedural language, PL/SQL, to take advantage of powerful features like stored procedures, functions, and triggers
- Pick up new skills whenever you want to or need to by focusing on material that’s new to you
- Look up coding details or refresh your memory on forgotten details when you’re in the middle of developing a database application
- Loan to your colleagues who are always asking you questions about Oracle SQL coding

To get your copy, you can order online at www.murach.com or call us at 1-800-221-5528 (toll-free in the U.S. and Canada). And remember, when you order directly from us, this book comes with my personal guarantee:

100% Guarantee

You must be satisfied. Each book you buy directly from us must outperform any competing book or course you’ve ever tried, or send it back within 60 days for a full refund…no questions asked.

Thanks for your interest in Murach books!